LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 11-28-2003, 04:34 PM   #1
drdroid
Member
 
Registered: Oct 2003
Location: Here
Distribution: Redhat 9.0
Posts: 124

Rep: Reputation: 15
problem with grub and windows 98se


when i attempt to boot windows 98se with grub i get that it's booting grub and it ends with 'GRUB'

this is the grub config file:

title DOS
rootnoverify (hd0,0)
chainloader +1
 
Old 11-28-2003, 06:59 PM   #2
homey
Senior Member
 
Registered: Oct 2003
Posts: 3,057

Rep: Reputation: 61
Has this setup worked before? or have you changed something?
Run the command: /sbin/fdisk -l so we can have a look at it please.
 
Old 11-29-2003, 12:47 PM   #3
drdroid
Member
 
Registered: Oct 2003
Location: Here
Distribution: Redhat 9.0
Posts: 124

Original Poster
Rep: Reputation: 15
Code:
 
            Boot:        Info:
hdb1        *            Win95 Fat32 (LBA)
hdb2                     Linux
hdb3                     Linux Swap
hdb4                     Win95 Ext'd (LBA)
hdb5                     Linux

Last edited by drdroid; 11-29-2003 at 12:49 PM.
 
Old 11-29-2003, 12:50 PM   #4
drdroid
Member
 
Registered: Oct 2003
Location: Here
Distribution: Redhat 9.0
Posts: 124

Original Poster
Rep: Reputation: 15
I'm not actually sure what that extra win95 partition is for, on hdb4. So what might ya think.
 
Old 11-29-2003, 02:50 PM   #5
drdroid
Member
 
Registered: Oct 2003
Location: Here
Distribution: Redhat 9.0
Posts: 124

Original Poster
Rep: Reputation: 15
yeah, its only about 1mb, it couldn't hold much...
 
Old 11-29-2003, 03:11 PM   #6
drdroid
Member
 
Registered: Oct 2003
Location: Here
Distribution: Redhat 9.0
Posts: 124

Original Poster
Rep: Reputation: 15
do you need more info?
 
Old 11-29-2003, 04:06 PM   #7
homey
Senior Member
 
Registered: Oct 2003
Posts: 3,057

Rep: Reputation: 61
Sorry, didn't see your reply.

Anywho, your partition table shows windows and linux on the second hard drive. That is most likely because you incorrectly have that drive set as secondary master with no other drive present.

That may still work if you change the grub.config from...
title DOS
rootnoverify (hd0,0)
chainloader +1


to...

title DOS
rootnoverify (hd1,0)
chainloader +1
 
Old 11-29-2003, 05:34 PM   #8
drdroid
Member
 
Registered: Oct 2003
Location: Here
Distribution: Redhat 9.0
Posts: 124

Original Poster
Rep: Reputation: 15
i get a message stating that the hardrive doesn't exist
 
Old 11-29-2003, 05:36 PM   #9
drdroid
Member
 
Registered: Oct 2003
Location: Here
Distribution: Redhat 9.0
Posts: 124

Original Poster
Rep: Reputation: 15
Quote:
Anywho, your partition table shows windows and linux on the second hard drive. That is most likely because you incorrectly have that drive set as secondary master with no other drive present.
How would I change the configuration to use the master hard drive?
 
Old 11-29-2003, 06:13 PM   #10
homey
Senior Member
 
Registered: Oct 2003
Posts: 3,057

Rep: Reputation: 61
Did Windows work before?

Go into the bios and see what the hard drive is configured as.
 
Old 11-30-2003, 08:35 AM   #11
drdroid
Member
 
Registered: Oct 2003
Location: Here
Distribution: Redhat 9.0
Posts: 124

Original Poster
Rep: Reputation: 15
Yeah, it did work before. Before I installed linux it was working perfectly.
 
Old 11-30-2003, 09:02 AM   #12
homey
Senior Member
 
Registered: Oct 2003
Posts: 3,057

Rep: Reputation: 61
You may get it to work with this setup. The map line tells the bios to treat disk 2 as if it is disk 1

title DOS
map (hd1) (hd0)
rootnoverify (hd0,0)
makeactive
 
Old 11-30-2003, 09:42 AM   #13
drdroid
Member
 
Registered: Oct 2003
Location: Here
Distribution: Redhat 9.0
Posts: 124

Original Poster
Rep: Reputation: 15
when i use that script, the screen goes black for a second and then goes back to grub.
 
Old 11-30-2003, 09:55 AM   #14
drdroid
Member
 
Registered: Oct 2003
Location: Here
Distribution: Redhat 9.0
Posts: 124

Original Poster
Rep: Reputation: 15
do you use irc or aim, we could do this alot faster if we used instant messaging.
 
Old 11-30-2003, 12:10 PM   #15
homey
Senior Member
 
Registered: Oct 2003
Posts: 3,057

Rep: Reputation: 61
Well surprise surprise! Yahoo has a messenger for " unix " which actually turned out to be linux. So I installed that on my Redhat box and my id is rctechy
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Windows 98SE as a secondary OS on RedHat9 sausagejohnson LinuxQuestions.org Member Success Stories 8 09-20-2004 06:03 PM
Networking Problem: Redhat 8.0 as a Server - Windows 98SE as clients Haxor Linux - Networking 10 03-19-2003 08:18 PM
Wine, samba and windows 98SE zhenwu Linux - Networking 3 02-14-2002 11:15 PM
how to boot mandrake8.0 in a windows 98se vicente Linux - Software 4 09-29-2001 11:36 PM
Windows me downgrade to 98SE cindy General 15 07-24-2001 12:50 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 03:01 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration