-   Linux - General (
-   -   Problem mounting a logical volume with JFS (

sumta 10-03-2006 08:12 AM

Problem mounting a logical volume with JFS
The system harddrive in my Fedora Core 4 box has recently died. I placed a new drive in the box and reinstalled, this time with Fedora Core 5. No problem. I am now (unsuccessfully) attempting to remount the second drive which is a logical volume with a JFS file system.

When I try to mount the volume, I get the following error:
# mount -t jfs /dev/MythVol/MythVideo /video

mount: wrong fs type, bad option, bad superblock on /dev/MythVol/MythVideo,
missing codepage or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

I did install support for the JFS file system.
The drive was recognized at install time as hdb1
The logical volume manager does see the volume, but lists the file system as "none"

dmesg | tail renders the following:

audit(1159853590.577:6): avc: denied { use } for pid=2855 comm="smbd" name="[8249]" dev=pipefs ino=8249 scontext=system_u:system_r:smbd_t:s0 tcontext=system_u:system_r:xdm_t:s0-s0:c0.c255 tclass=fd
audit(1159853591.513:7): avc: denied { use } for pid=2858 comm="nmbd" name="null" dev=tmpfs ino=1243 scontext=system_u:system_r:nmbd_t:s0 tcontext=system_u:system_r:xdm_t:s0-s0:c0.c255 tclass=fd
audit(1159853591.517:8): avc: denied { write } for pid=2858 comm="nmbd" name="[10198]" dev=pipefs ino=10198 scontext=system_u:system_r:nmbd_t:s0 tcontext=system_u:system_r:unconfined_t:s0 tclass=fifo_file
audit(1159853591.517:9): avc: denied { use } for pid=2858 comm="nmbd" name="[8249]" dev=pipefs ino=8249 scontext=system_u:system_r:nmbd_t:s0 tcontext=system_u:system_r:xdm_t:s0-s0:c0.c255 tclass=fd
nvidia: no version for "struct_module" found: kernel tainted.
nvidia: module license 'NVIDIA' taints kernel.
ACPI: PCI Interrupt Link [APC4] enabled at IRQ 19
ACPI: PCI Interrupt 0000:04:00.0[A] -> Link [APC4] -> GSI 19 (level, high) -> IRQ 217
NVRM: loading NVIDIA Linux x86 Kernel Module 1.0-8774 Tue Aug 1 20:54:08 PDT 2006
JFS: nTxBlock = 1998, nTxLock = 15984

Any pointers would be greatly appreciated.


haertig 10-03-2006 09:12 AM

Run vgscan, followed by vgchange -a y. Then try your mount command. You may need to run modprobe dm-mod before all of the above, but I doubt it.

sumta 10-05-2006 09:30 AM

Thanks Haertig, that got me closer. I ended up having to fsck.jfs -a the volume. Once I did that, I could mount it. Now I just need to get the thing to automount and life will be good till the next issue.

haertig 10-05-2006 11:49 AM


Now I just need to get the thing to automount...
Try adding the following line to your /etc/fstab file:

/dev/mapper/MythVol-MythVideo  /video  jfs  defaults  0  2
It should automount the next time you boot, or you can manually run mount /video or umount /video to mount or unmount it.

All times are GMT -5. The time now is 06:28 PM.