LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (https://www.linuxquestions.org/questions/linux-general-1/)
-   -   problem configuring X on debian(woody) (https://www.linuxquestions.org/questions/linux-general-1/problem-configuring-x-on-debian-woody-111064/)

n3tw0rk 11-01-2003 06:56 AM

problem configuring X on debian(woody)
 
I recently installed debian(woody), i tried compiling the latest kernel into it i.e 2.4.22, actually i am using a pentium 4 with the built-in VGA/AGP support, my mobo is intel 845GEBV2, i checked out redhat 9.0, the X configuration file in redhat contains the module named "i810" in the device section, the info about the module i810 in redhat states that it also supports I845G boards, the problem is that in debian when i compile the i810 as a module, it gets installed, when the kernel loads it says that an Intel Chipset 845G has been detected, i have also configured the framebuffer driver for I845G which works fine, but when i try to start X in debian it gives an error, moreover the error states that i810 module only support, i810, and i815 not i845(which is the main problem), how to get around with this?, it aso prompted for some BusID, which i checked out from redhat and it was "00:02:0"

Bruce Hill 11-07-2003 02:44 AM

Since you haven't gotten a reply on this in a few days, perhaps my little bit of information may at least help get you down the road. I installed Debian Woody and then updated to kernel 2.4.22. This is the only advice I can give you. My board is an Asus P4PE (845PE chipset) which I believe has the same VGA/AGP support as your board. I run a P4 2.4GHz, and have an ATI Radeon 9000 AGP 4X (which I haven't installed the driver for yet). Even though I have a 845PE, dmesg says ->
agpgart: Detected Intel(R) 845G chipset

At any rate, these are the entries from /boot/config-2.4.22paul (my new kernel) and from /etc/X11/XF86Config-4 ->

# Ftape, the floppy tape device driver
#
# CONFIG_FTAPE is not set
CONFIG_AGP=y
CONFIG_AGP_INTEL=y
CONFIG_AGP_I810=y
CONFIG_AGP_VIA=y
CONFIG_AGP_AMD=y
# CONFIG_AGP_AMD_8151 is not set
CONFIG_AGP_SIS=y
CONFIG_AGP_ALI=y
# CONFIG_AGP_SWORKS is not set
# CONFIG_AGP_NVIDIA is not set
CONFIG_DRM=y
# CONFIG_DRM_OLD is not set

(I see that I've left some AGP sets in there I don't need, i.e. VIA, AMD, SIS, ALI. Don't know how those got by me.)

#
# DRM 4.1 drivers
#
CONFIG_DRM_NEW=y
CONFIG_DRM_TDFX=y
# CONFIG_DRM_R128 is not set
CONFIG_DRM_RADEON=y
CONFIG_DRM_I810=y
CONFIG_DRM_I810_XFREE_41=y
# CONFIG_DRM_I830 is not set
# CONFIG_DRM_MGA is not set
# CONFIG_DRM_SIS is not set


Code:

Section "Module"
        Load    "GLcore"
        Load    "bitmap"
        Load    "dbe"
        Load    "ddc"
        Load    "dri"
        Load    "extmod"
        Load    "freetype"
        Load    "glx"
        Load    "int10"
        Load    "pex5"
        Load    "record"
        Load    "speedo"
        Load    "type1"
        Load    "vbe"
        Load    "xie"
EndSection

Section "Device"
        Identifier      "Generic Video Card"
        Driver          "vesa"
        Option          "UseFBDev"              "true"
EndSection

It may be helpful, also, if you were to look at your
$ /boot/config-2.4.18-bf2.4
you may find something that you changed when you compiled the 2.4.22 kernel.

And run $ cat /proc/pci to find out the correct Bus ID.

Hope this somehow helps you.


All times are GMT -5. The time now is 07:58 AM.