LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 02-29-2012, 05:12 AM   #1
edbarx
Member
 
Registered: Sep 2010
Distribution: Used Debian since Sarge. (~2005)
Posts: 373

Rep: Reputation: 20
Privoxy is failing to start upon boot.


I set up privoxy as an internet filter but it is failing to start upon boot almost every time I boot my machine. To set it running, I need to become root and run:
Code:
/etc/init.d/privoxy start
I searched for a solution and tried to edit /etc/privoxy/config's line:
Code:
listen-address localhost:8118
I replaced localhost with [::1] but then I couldn't configure iceweasel to use privoxy.

Any help is appreciated.
 
Old 02-29-2012, 05:18 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1977Reputation: 1977Reputation: 1977Reputation: 1977Reputation: 1977Reputation: 1977Reputation: 1977Reputation: 1977Reputation: 1977Reputation: 1977Reputation: 1977
is it failing to start, or is it not being asked to start in the first place? On debian, I think this would be done with "update-rc.d privoxy defaults". If it's not a trivial issue like that, then check your logs to investigate what it does say when it doesn't start, /var/log/messages etc.
 
Old 02-29-2012, 06:03 AM   #3
edbarx
Member
 
Registered: Sep 2010
Distribution: Used Debian since Sarge. (~2005)
Posts: 373

Original Poster
Rep: Reputation: 20
This is what I found in /var/log/privoxy/logfile:
Code:
Fatal error: can't bind to 127.0.0.1:8118: The hostname is not resolvable
This means, upon boot the system is trying to start privoxy but for some weird reason it is failing.
 
Old 02-29-2012, 06:08 AM   #4
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1977Reputation: 1977Reputation: 1977Reputation: 1977Reputation: 1977Reputation: 1977Reputation: 1977Reputation: 1977Reputation: 1977Reputation: 1977Reputation: 1977
it sounds like it's trying to start up before the network interfaces have started. Change the start time of the script to S99 or something like that. Even if your external connections are managed through NetworkManager or such, I'm sure lo will always come up statically. So why is that not resolvable earlier in the boot process when it is later? Not sure exactly what it's meaning by "resolvable".... do you have legitimate entries setup for localhost in /etc/hosts? That's the other option for explaining "resolvable" as I see it.
 
Old 02-29-2012, 06:09 AM   #5
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 17,253

Rep: Reputation: 2640Reputation: 2640Reputation: 2640Reputation: 2640Reputation: 2640Reputation: 2640Reputation: 2640Reputation: 2640Reputation: 2640Reputation: 2640Reputation: 2640
Has Debian finally got around to using systemd ?.
I've found that the privoxy init scripts seem valid, but don't run properly on Fedora. I gave up chasing the reason, and just start it in rc.local
 
Old 02-29-2012, 06:54 AM   #6
edbarx
Member
 
Registered: Sep 2010
Distribution: Used Debian since Sarge. (~2005)
Posts: 373

Original Poster
Rep: Reputation: 20
Quote:
do you have legitimate entries setup for localhost in /etc/hosts? That's the other option for explaining "resolvable" as I see it.
This is a part of my /etc/hosts file:
Code:
127.0.0.1       localhost
127.0.1.1       ***removed**** 

# The following lines are desirable for IPv6 capable hosts
::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

127.0.0.1       www.google-analytics.com
/etc/network/interfaces
Code:
# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
iface eth0 inet dhcp
 
Old 02-29-2012, 09:38 AM   #7
sundialsvcs
LQ Guru
 
Registered: Feb 2004
Location: SE Tennessee, USA
Distribution: Gentoo, LFS
Posts: 9,078
Blog Entries: 4

Rep: Reputation: 3171Reputation: 3171Reputation: 3171Reputation: 3171Reputation: 3171Reputation: 3171Reputation: 3171Reputation: 3171Reputation: 3171Reputation: 3171Reputation: 3171
The order in which startup is being attempted is probably the culprit. No, it doesn't make too much sense that an obvious IP-address would require "name resolution" but maybe Privoxy thinks otherwise. You are probably starting it too soon.
 
Old 02-29-2012, 05:48 PM   #8
edbarx
Member
 
Registered: Sep 2010
Distribution: Used Debian since Sarge. (~2005)
Posts: 373

Original Poster
Rep: Reputation: 20
As I have been searching and reading about this issue and found no solutions that could work on my system, I have uninstalled privoxy and set up a huge hosts file to filter ads and unwanted sites. However, I would still be very greatful is somebody finds a solution and posts it here in this thread.

Thanks for all your contributions. Apart from this nagging bug, privoxy worked perfectly.
 
Old 02-29-2012, 06:16 PM   #9
craigevil
Senior Member
 
Registered: Apr 2005
Location: OZ
Distribution: Debian Sid
Posts: 4,734
Blog Entries: 12

Rep: Reputation: 462Reputation: 462Reputation: 462Reputation: 462Reputation: 462
Try removing it then reinstaling it.

Worked here with no problems when I had it installed.


Recently switched to using polipo with tor as it seems faster.

Why not use Adblock or one of the other adblocking extensions? What browser are you using?

You can install and use sysv-rc-conf to check when it is set to start, by default the run levels are 2345.
 
Old 02-29-2012, 06:31 PM   #10
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 17,253

Rep: Reputation: 2640Reputation: 2640Reputation: 2640Reputation: 2640Reputation: 2640Reputation: 2640Reputation: 2640Reputation: 2640Reputation: 2640Reputation: 2640Reputation: 2640
Quote:
Originally Posted by craigevil View Post
Recently switched to using polipo with tor as it seems faster.
Cough ... cough.
Don't do that, I almost choked on my coffee ....

tor ... faster ... ????
Here ???

'spose I'd better go check.
 
Old 03-01-2012, 03:15 AM   #11
edbarx
Member
 
Registered: Sep 2010
Distribution: Used Debian since Sarge. (~2005)
Posts: 373

Original Poster
Rep: Reputation: 20
Quote:
Originally Posted by craigevil View Post
Try removing it then reinstaling it.

Worked here with no problems when I had it installed.


Recently switched to using polipo with tor as it seems faster.

Why not use Adblock or one of the other adblocking extensions? What browser are you using?

You can install and use sysv-rc-conf to check when it is set to start, by default the run levels are 2345.
I reinstalled privoxy but it didn't solve the problem. I use iceweasel v. 3.5.16 on Debian Squeeze. The Adblock version available is not compatible with my version of iceweasel and I don't want to migrate to Testing or Unstable as there is still the backlight bug.

In the past, I tried sysv-rc-conf and borked my system and I had to reinstall.
 
Old 03-27-2012, 11:44 AM   #12
edbarx
Member
 
Registered: Sep 2010
Distribution: Used Debian since Sarge. (~2005)
Posts: 373

Original Poster
Rep: Reputation: 20
Installed Wheezy although there is still the backlight bug. I used /etc/rc.local to run the setpci command as soon as all startup scripts are finished.

Privoxy is now starting as it should.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Privoxy doesn't always start on boot Suppen Linux - Software 10 12-26-2009 10:41 AM
Privoxy doesn't start at boot Amdx2_x64 Linux - Newbie 3 08-10-2008 08:16 AM
Privoxy - "Privoxy is not being used" from http://www.privoxy.org/config/ slimjim Linux - Networking 1 03-12-2007 12:07 PM
Privoxy won't start on boot (Slackware) bleedingturnips Linux - Software 2 07-13-2006 08:51 AM
privoxy start up script thegreatgatsby Linux - Software 4 05-28-2004 06:34 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 12:28 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration