-   Linux - General (
-   -   Printer resolution low after upgrade to Fedora 14 (

geustace 11-28-2010 01:38 PM

Printer resolution low after upgrade to Fedora 14
I have just upgraded my desktop to Fedora 14 from 12, I have been quite happily printing postscript documents via CUPS to an Epson CX9300F for ages. After the upgrade ( rather re-install as the boot partition wasn't big enough ) The documents come out looking like they were printed on an old Apple deskwriter, i.e. very pixel-lated.

I cannot seem to find what or where one has to tweak things to get it too work. I have tried both CX9300 drivers as supplied with the OS. I have tried system-config-printer and changed the resolution from auto to 370. So far no luck.

Any clues what to do would be appreciated.

smoker 11-28-2010 03:30 PM

Have you installed the Gutenprint drivers ?
They usually give good results with Epson printers.

You should find the Gutenprint drivers in add/remove software. Just search for gutenprint.

geustace 11-29-2010 01:59 PM

Yes, the gutenprint drivers are included in Fedora 14 . They used to be in 12 as well. I have tried both of the ones suggested in system-config-printer.

A postscript document printed via cups to the Epson ( which is actually hosted on a Windows PC with an LPD print queue, though this hasn't changed so I am discounting that for the moment ), I believe gets rendered by gs comes out pixelated. Normal printing from say OpenOffice to this printer works just fine.

I am suspecting there is a setting somewhere that has changed and now needs tweaking as this had been working fine with 12 and now fails with 14 :-( Maybe gs is getting given the wrong paramters ? If so, where does one teak the cups/gs interface ?

smoker 11-29-2010 04:05 PM

You've lost me I'm afraid as the gutenprint drivers definitely were not included in F12 and that's what I'm running now. Ghostscript problems are a separate issue altogether I think.

geustace 11-29-2010 08:47 PM

From my cups/printers.conf file from my Fedora 12 system ( restored from the pre-update backup )

MakeModel Epson Stylus CX9300F Foomatic/gutenprint-ijs-simplified.5.2

Looks like a gutenprint driver to me :-(

Hmm didn't occur to me until now to check for differences.

In the old config it has

Filter application/vnd.cups-postscript 100 foomatic-rip
Filter application/vnd.cups-pdf 0 foomatic-rip

in the new

Filter application/vnd.cups-raster 100 rastertogutenprint.5.2

I suppose I need to find out how to configure filters :-(

geustace 12-01-2010 04:15 PM

After much mucking around, the solution turned out to be the postscript not the printing subsystem. The postscript that has been rendered poorly through rastertogutenprint-5.2 yet worked fine through the previous filter, foomatic-rip, seems to need some additional stuff in it in order to render correctly. It seems if paper size and quality are not specified in the postscript, regardless of what is on the options for the printer I get 'Letter' and the lowest resolution the printer has.


%%BeginFeature: *PageSize Default
<< /PageSize [ 595 842 ] /ImagingBBox null >> setpagedevice
<< /HWResolution[360 360] /cupsRowFeed 6 >> setpagedevice

gives me the same quality output I used to get on A4.

I hope my research might be of use to someone else :-)

stress_junkie 12-01-2010 04:22 PM

Thank you for posting the answer. The Great and Powerful Google will read your post and then the world will know of your solution. :)

All times are GMT -5. The time now is 08:09 PM.