-   Linux - General (
-   -   Print job stops, will not print OS: Fedora 16, Printer Samsung ML-2955ND (

Entwicklung 02-14-2013 08:31 PM

Print job stops, will not print OS: Fedora 16, Printer Samsung ML-2955ND
2 Attachment(s)
Printer is installed, it has printed two test pages. Cannot get it to print anything else. Have restarted cups multiple times and re-booted computer, and unplugged/plugged printer. Any help most greatly appreciated.

John VV 02-14-2013 11:54 PM

first fedora 16 is as you know now past it's end of life

time to think about installing fedora 18

the gui in fedora is ?? well bluntly "bad " ( and smelly )

use the cups web interface

i am betting there are files in the print que that are blocking it

click on the "jobs" tab and kill any that are there

Entwicklung 02-15-2013 07:25 AM

Here is the error message I get from CUPS: "/usr/lib/cups/filter/rastertosamsungspl failed"

I've downloaded 18 and will be installing it soon.

John VV 02-15-2013 12:18 PM


"/usr/lib/cups/filter/rastertosamsungspl failed"
?? you are getting that is Firefox 18 ???? when you go to the "localhost" Web address ??

and NOT getting a 404 error ?

if so then there is something VERY messed up with fedora 16

Entwicklung 02-16-2013 10:45 AM

No, I'm getting that error message in 16. I haven't installed 18 yet. Do you think that installing 18 would fix the problem?

Entwicklung 02-16-2013 11:07 AM

Screenshot of CUPS when tried to print test page
1 Attachment(s)
I cancelled all stopped jobs and tried to print test page. Got same results. Checked to see if rastertosamsungspl file was in /usr/lib/cups/filter. It was.

kavadias 05-17-2013 11:11 AM

I have the same problems using Fedora 17...

I realize this is an old post, but can anyone please help on this issue?

DavidMcCann 05-17-2013 12:32 PM

The Samsung documentation warns that their printers are not compatible with SELinux. So, before printing I use the command (as root)
setenforce 0
and afterwards
setenforce 1
and my Samsung works perfectly.

I did try checking and correcting the SEL labeling of all the relevant files, and that got the printer to print a page: size! It really doesn't like SEL.

kavadias 05-17-2013 01:37 PM


It works perfectly after setenforce 0.

Thank you so much!

Entwicklung 05-18-2013 09:00 AM

I think I did the setenforce 0 as root. Didn't work either so I just concluded that Samsung isn't Linux friendly and plugged the printer into my Windows machine and just print from there.

All times are GMT -5. The time now is 12:12 AM.