-   Linux - General (
-   -   Print function has gone Poof (

jhimes 09-01-2005 10:19 PM

Print function has gone Poof
I've just lost my ability to print.

I'm running SuSe 9.1 Pro on an IBM Thinkpad T30. I installed the distro earlier this year, and configured three different printers, which have functioned fine.

Yesterday, I lost all print function. Documents queue but as soon as they do the printer stops. Restarting is futile. I've tried two of the printers. Same result. Reinstalling does nothing.

I'm not a techie. I've no idea where to start to trouble shoot this. This may have something to do with my attempts to sync a new Treo 650, although if it does, I've no idea why. I did some ownership changing from root to user in /dev/.

I'd be grateful if anyone can help me start to figure this out.

cswor 09-02-2005 04:47 PM

as an experiment, you might go back and try backing out those ownership changes you made in /dev. i created quite a mess with a wildcard chown in the wrong directory. what a pain. this may not be it. just make a few notes about what you change as you may need to put it back.

are you trying to print as a normal user and have you tried to print as root? let us know what you find.

jhimes 09-02-2005 11:07 PM

It's Gotten Worse: Really Need Help
I've made matters far worse.

The changes in ownership that I referred to in my first post were to /dev and /var. This is a personal computer that only I use. I changed ownership from root to my user name, jay, and the group from root to users.

I think that I've managed to change back using chown and wildcards. I tried to change everything to root.root. But for whatever reason, my problems are worse.

First, I've now discovered that, while a user, I cannot go into root or su. I'm running KDE. If, while user, I need to go into, say, Yast, that requires me to log in as root. When I put in the root password, the message back is "The Program su is not found. Make sure your PATH is set correctly."

I've got to fix this. Where do I start.

Second, I can't use Shell Konsole. If I launch it, I just get a blank screen with a black rectangle in the upper left. It does not show my login.

I'll emphasis that I've got no real tech background. I've been running Linux for a year to get off Windows as my personal computer.


cswor 09-03-2005 10:26 AM

sorry about the owner/privileges problems. thats exactly the type of problem that i got into for slightly different reasons but same effect. you will find that many processes, like ftp, mail, etc., have a user account with the same name. often these are not login accounts, but needed by the system for these things to function. they also must "own" related processes. this is where you and i got bitten.

i believe su is locate in /bin. you should be able to execute /bin/su to get into the root account unless there is a more serious problem.

one possible fix would be to try reloading the system. not from scratch. in particular, you don't want to repartition or format your disk(s). that would wipe out any additional data/software you have on the system. in fedora/red hat, you can get to the point where it is displaying the partition tables, select edit for each one, and select the "do not format" option. on packages, select minimum and give it a try. it may freshen up the ownerships and correct the problems you now have while preserving things you have added. not a guarantee, and you do need to make sure not to reformat! if

a second possible fix, if you have another system, you can manually/tediously go through the directories affected by your ownership changes and make the afflicted system match the good one. that is what i did. tedious is the key word and you need that other system.

be careful if you try the first option. i have wiped out systems with a mis-step going this route. of course, they were home systems and i could afford a screwup. if you don't have the second system to use as a guide, i could probably dump a long directory list to a file and mail it to.

jhimes 09-03-2005 05:07 PM

I can get into the root account by switching users. Indeed, I now find I can't much function in the user account without going to root to launch applications that need su.

I don't have a second system. This is just a home computer. I can backup and do a re-install, although it will be frustrating getting back to where I was.

All times are GMT -5. The time now is 01:08 PM.