LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 11-24-2002, 08:10 AM   #1
Zola
LQ Newbie
 
Registered: Nov 2002
Location: UK
Posts: 1

Rep: Reputation: 0
Question POP3 problems


Hey,
I wanted to setup a small mail server so that I could send and receive e-mail from a domain I registered on dyndns.org.

So I installed sendmail and POP3, I can send e-mail ok using sendmail.
But I'm not sure if I have configured POP3 right, I have tried several times to send e-mail to it from different e-mail accounts I have and they never seem to get to my POP3 inbox.

I have tried sending them all like this:

Blake@127.0.0.1
(replaced 127.0.0.1 with my real ip address)

Blake@my-hostname.my-isp.co.uk

Blake@my-dyndns-domain-name.org

I log into my account by telneting to 127.0.0.1 on port 110 (the port it is running on), then I log into the POP3 server by typing USER Blake, PASS my-password. But there is never any new e-mail there.

Does anybody know what the problem is here?...
Any replies would be much appreicated,
Thanks
Blake
 
Old 12-05-2002, 10:35 PM   #2
starheart
LQ Newbie
 
Registered: Dec 2002
Location: Reno, Nevada
Distribution: RedHat
Posts: 22

Rep: Reputation: 15
Sounds like you don't have sendmail setup correctly to receive mail. Two things you have to do to setup sendmail to accept mail are add the domain you want it to receive mail for into /etc/mail/local-host-names. The second is required on redhat at least. It is that you have to edit /etc/mail/sendmail.mc and comment out the line that says to only listen on localhost. Then run the command at the top of the file and restart sendmail. You should also double check that you have your mx record for the domain set right.
 
Old 12-06-2002, 01:14 AM   #3
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
check to see if you have mail by using

mail

then when you do have mail pop3 should work
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
POP3 Imap Problems Cynthia Blue Linux - Software 2 11-13-2004 10:55 PM
Cyrus21-pop3 problems blood_omen Debian 1 07-24-2004 11:46 AM
POP3 problems IgD Linux - Newbie 1 09-28-2003 05:02 PM
mail (sendmail+pop3) problems... sqn Slackware 42 03-30-2003 04:08 PM
POP3/SMTP-IPTABLES Problems chris Linux - Networking 1 02-28-2003 04:55 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 02:21 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration