LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 05-27-2012, 01:01 AM   #1
hungryninja101
LQ Newbie
 
Registered: May 2012
Posts: 14

Rep: Reputation: Disabled
Question parted doesn't detect partition type


I want to copy an ext3 partition using gparted, but under type, it says unknown. I tried using the command line version of parted (parted /dev/sda print), but it didn't show the partition type either. I can mount this partition. I can boot to it. I ran e2fsck /dev/sda1 -f, which didn't detect any problems. What is wrong and how can I fix it?
 
Old 05-27-2012, 01:04 AM   #2
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 15,989

Rep: Reputation: 2217Reputation: 2217Reputation: 2217Reputation: 2217Reputation: 2217Reputation: 2217Reputation: 2217Reputation: 2217Reputation: 2217Reputation: 2217Reputation: 2217
Let's see (as root) "fdisk -l".
 
Old 05-27-2012, 01:07 AM   #3
hungryninja101
LQ Newbie
 
Registered: May 2012
Posts: 14

Original Poster
Rep: Reputation: Disabled
Disk /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xf58f17f0

Device Boot Start End Blocks Id System
/dev/sda1 1 657 5277321 83 Linux
/dev/sda2 * 658 6542 47271262+ 7 HPFS/NTFS
/dev/sda3 6543 9461 23446867+ 83 Linux
/dev/sda4 9462 9729 2152710 82 Linux swap / Solaris
Note: sector size is 2048 (not 512)
 
Old 05-27-2012, 01:21 AM   #4
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 15,989

Rep: Reputation: 2217Reputation: 2217Reputation: 2217Reputation: 2217Reputation: 2217Reputation: 2217Reputation: 2217Reputation: 2217Reputation: 2217Reputation: 2217Reputation: 2217
Can you explain the note at the bottom ?.
 
Old 05-27-2012, 07:11 PM   #5
hungryninja101
LQ Newbie
 
Registered: May 2012
Posts: 14

Original Poster
Rep: Reputation: Disabled
Question

No, but the problem is only with /dev/sda1. I tried a libparted and gparted upgrade, but that didn't help. I tried partitionmanager (kde) from /dev/sda3, but that didn't work either.

Last edited by hungryninja101; 05-27-2012 at 07:12 PM. Reason: clarify
 
Old 05-27-2012, 07:25 PM   #6
hungryninja101
LQ Newbie
 
Registered: May 2012
Posts: 14

Original Poster
Rep: Reputation: Disabled
also, gnome disk utility and disk manager show type as unknown.
 
Old 05-27-2012, 08:00 PM   #7
hungryninja101
LQ Newbie
 
Registered: May 2012
Posts: 14

Original Poster
Rep: Reputation: Disabled
I tried to mount /dev/sda1 later, but it couldn't read superblock. When I tould mount that it was ext3 (-t ext3), it worked.

I found this out because I accidentally moved /usr into /var and fished it out.
 
Old 05-27-2012, 08:35 PM   #8
unSpawn
Moderator
 
Registered: May 2001
Posts: 29,361
Blog Entries: 55

Rep: Reputation: 3547Reputation: 3547Reputation: 3547Reputation: 3547Reputation: 3547Reputation: 3547Reputation: 3547Reputation: 3547Reputation: 3547Reputation: 3547Reputation: 3547
Quote:
Originally Posted by hungryninja101 View Post
Code:
Note: sector size is 2048 (not 512)
Any chance there's another device connected like an MP3 player, USB stick or whatever else device that's not a regular spindle and platters hard disk?
 
Old 06-07-2012, 12:07 PM   #9
hungryninja101
LQ Newbie
 
Registered: May 2012
Posts: 14

Original Poster
Rep: Reputation: Disabled
I eventually copied everthing over using tar, but it would still be helpful for others to know how to fix this problem.

I don't know whether my ipod is interfering, so I will try unplugging it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Debian Squeeze grub doesn't detect windows partition on install Cultist Debian 3 05-17-2011 05:26 PM
parted doesn't see display name when partition is reiser4 or btrfs robertjinx Linux - Software 2 08-08-2010 03:19 AM
mandriva dual boot filesystem type unknown,partition type 0x7 llearner Linux - Newbie 2 01-24-2010 03:03 PM
Dual Boot Vista Suse 10.2 error setting type of partition to type 82 jmp559 Linux - General 1 05-15-2008 07:40 PM
How do I partition my hd using parted? thanhthanh19 Fedora 3 10-23-2004 05:39 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 10:43 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration