-   Linux - General (
-   -   OpenSUSE 12.2 USB won't boot (

antitankknife 02-21-2013 07:04 PM

OpenSUSE 12.2 USB won't boot
I have tried Universal USB installer and LiLi USB creator to no avail. They only support up to 12.1. I tried using SUSE studio imagewriter, but it keeps telling me it cannot access the device even though I am running as an admin. I have tried for 3 hours to get this to work and I am too pissed off to continue right now. Any way to get the .iso to boot off a USB for 12.2?

jefro 02-21-2013 09:18 PM

There may be a way. Not all distro's can boot from grub or grub4dos. I believe there are web pages at www.pendrivelinux for many ways. Even a multi loader usb.

Your issue may be more than that. I'd wonder why you can't use tools. I assume you are in windows. Those installers use syslinux in their program an it needs to write to the flash drive. That may be what is stopping it. As to why I can't guess.

I don't usually make those types of installs. I prefer using real installs to the usb. Still kind of tricky. Easiest way is to use installers.

antitankknife 02-23-2013 01:10 PM

I am running Win 7 x64. I still have not found a way to get the f-ing USB to boot. It pisses me off that I can mount the ISO in VirtualBox and it installs and runs just fine, but when I try it for real, my computer won't boot the USB. It sticks just after the BIOS, and tries to read the USB, but can't because it won't write the boot files apparently. It irritates me that pendrivelinux still doesn't have support for OpenSUSE 12.2 but it does for 12.1.

John VV 02-23-2013 01:47 PM

during boot ( before the windows bootloder is displayed )
you should have the option of hitting <f2> or < f12> ( might be < f10> )
f2 sets up the bios
f12 or f10 selects the boot option ( what to boot from )
different manufactures do things differently so yours might be different

also that usb thumb drive might not have the operating system installed correctly on it

Microsoft royally "bleeped up" the uac
even from the Administrator account you NEED to use the start menu and look for
" run 'program name' and administrator "

i would "BURN AS A IMAGE!!! the suse 12.2 iso to a dvd
put the usb thumb drive in the slot
and the dvd in the drive
then reboot
( after setting the bios to BOOT from dvd FIRST )
use the dvd to do a persistent install of suse12.2 to the usb thumb drive
take EXTRA CARE !!!!!!
to install grub2 TO THE USB !!!!!
and not the the harddrive !!!

antitankknife 02-23-2013 01:55 PM

@John It was reading the USB but the proper boot files were not installed to the USB.

I am typing this as I speak on OpenSUSE 12.2. This is probably the quickest, smoothest, and one of the nicest looking distros, KDE or otherwise, I have used. It runs MUCH MUCH better than virtual box since it can take full advantage of my hardware.

I used SUSE studio imagewriter to install the ISO to USB. The problem was that the USB had to be RAW format, not FAT or NTFS. This was a pain in the ass to find in Google, but I finally got it by using diskpart and the CLEAN command. That made the USB RAW formatted so I was able to use imagewriter.

John VV 02-23-2013 02:10 PM

i reformat my usb thumb drives as ext4
then install the os to it using a dvd

there are many ways but that for me is the easiest

antitankknife 02-23-2013 02:19 PM

I don't know why SUSE is so different from the rest of Distros I have used for install. =/

John VV 02-23-2013 03:29 PM

novell dose things very differently than other rpm based distros

it is almost a merge of red hat and debian , but updated to newer software .

SUSE is targeted for the office and they need to be DIFFERENT than red hat so , it is different .

jefro 02-25-2013 11:12 AM

"I used SUSE studio imagewriter to install the ISO to USB. The problem was that the USB had to be RAW format,"

I have used dd for windows and that alone should have been like dd on linux. It would simply copy over the contents of the image to the usb bit by bit. This would assume you created a usb image in Studio and not a live cd.

I like SuseStudio a lot. Only issue with it is you need to be very careful about building it with all the tools you need. I get used to a full distro and find that I have to go back and make new versions with added tools.

All times are GMT -5. The time now is 12:56 AM.