LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 04-21-2005, 03:33 PM   #1
mmmm
Member
 
Registered: Oct 2004
Location: Poland
Distribution: Slack 10.1, Mandrake 10.1
Posts: 118

Rep: Reputation: 15
OpenGL very slow, SIS300


Hi,
I've got Slackware 10.1 on Asrock G Pro motherboard.
I use build-in graphics (SIS300/315), Xorg.
All programs using OpenGL are working very slow. For example :
I run SuperTux (great game !!!) without option "use OpenGL" selected.
Everything is ok, about 50FPS.
But when "use openGL" is selected, it is VERY slow.
First it displays 1.0 FPS. Then, after about 1sec it is 100FPS. Then 1.0 - 5.0 and 90-100FPS, ......................
And it's not possible to play...

------------------------------------------------
1.70 celeron
Asrock G Pro (build-in graphics,sound)
192Mb RAM (+ 64M for graphics)
 
Old 04-22-2005, 04:14 PM   #2
SciYro
Senior Member
 
Registered: Oct 2003
Location: hopefully not here
Distribution: Gentoo
Posts: 2,038

Rep: Reputation: 51
sounds like direct rendering is not enabled (direct rendering is the X/whatever term for hardware acceleration (its also shorter))

type
Code:
glxinfo | grep direct
it will tell you if its on or not.

if its off, then all rendering is done on the CPU, which is ssssllllooooowwwww (even if you have a fast-ish CPU (but i have not tried it on a 64-bit before, or dual core (now, dual core with 64-bit ..... (treading on, to take advantage), that would be a nice test)
 
Old 04-23-2005, 01:51 PM   #3
mmmm
Member
 
Registered: Oct 2004
Location: Poland
Distribution: Slack 10.1, Mandrake 10.1
Posts: 118

Original Poster
Rep: Reputation: 15
You're right.

Code:
 
  # glxinfo |grep direct
  direct rendering: No
 OpenGL renderer string: Mesa GLX Indirect
 #
How can I enable direct rendering?
 
Old 04-23-2005, 02:44 PM   #4
SciYro
Senior Member
 
Registered: Oct 2003
Location: hopefully not here
Distribution: Gentoo
Posts: 2,038

Rep: Reputation: 51
first, you need a appropriate kernel

in the kernel you must have a agpgart for your motherboard (if your video uses agp)

next use need the drm driver for your card

these options are somewhere in the device driver section for 2.6 kernels

after you config your display with 'xorgconfig' you will need to edit the xorg.conf file (xorgconf seems to make mistakes, where a small hand edit will fix), uncomment the lines concerning the glx and dri parts

then add the dri section (i forget what it looks like, a search should find it, but it contains 1 line like 'mode 666' or such.
 
Old 04-24-2005, 02:52 PM   #5
mmmm
Member
 
Registered: Oct 2004
Location: Poland
Distribution: Slack 10.1, Mandrake 10.1
Posts: 118

Original Poster
Rep: Reputation: 15
I've recompiled kernel.
lsmod gives :
Code:
Module                  Size  Used by
sis                           11328       0
drm                        61844        1 sis
uhci_hcd               32012       0
sis_agp                 7300          1
i2c_sis96x            5764          0
i2c_core                19968       1 i2c_sis96x
ohci_hcd               34312        0
sis900                   19332        0
nls_iso8859_1    4864           1
ide_scsi                14980        0
agpgart                 30384        2 drm,sis_agp
genrtc                   6156          0
I think everything I need is here.
I 've added to xorg.conf :

Load "glx"
Load "dri"
.............
Section "DRI"
Mode 0666
EndSection

But it is still not working!
glxinfo still says "direct rendering: No"
What more can I do?
 
Old 04-24-2005, 05:08 PM   #6
SciYro
Senior Member
 
Registered: Oct 2003
Location: hopefully not here
Distribution: Gentoo
Posts: 2,038

Rep: Reputation: 51
either the driver in your xorg.conf is wrong, or the drivers in your kernel are wrong, or, DRI doesn't support your card.

recheck the kernel config, use "lspci" to double check your hardware
 
Old 04-25-2005, 07:47 AM   #7
mmmm
Member
 
Registered: Oct 2004
Location: Poland
Distribution: Slack 10.1, Mandrake 10.1
Posts: 118

Original Poster
Rep: Reputation: 15
I think DRI doesn't suppors SIS300...

I have to buy other graphics card....
 
Old 04-25-2005, 12:57 PM   #8
SciYro
Senior Member
 
Registered: Oct 2003
Location: hopefully not here
Distribution: Gentoo
Posts: 2,038

Rep: Reputation: 51
http://dri.freedesktop.org/wiki/SiS300

it does maybe? ........... but it looks as tho maybe the 3D is not working fully? ..... i dono

Last edited by SciYro; 04-25-2005 at 12:58 PM.
 
Old 04-26-2005, 02:40 PM   #9
mmmm
Member
 
Registered: Oct 2004
Location: Poland
Distribution: Slack 10.1, Mandrake 10.1
Posts: 118

Original Poster
Rep: Reputation: 15
I've searched in Xorg logs, and I've found :

Code:
................
(II) Loading extension XFree86-DRI
..........................
(**) SIS(0): Option "DRI" "True"
(**) SIS(0): DRI enabled
.................................................
(NI) SIS(0): DRI not supported on this chipset 
(II) SIS(0): Direct rendering disabled
.................

X doesn't support it .............
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenGL screensaver slow openfun Debian 5 09-08-2005 08:07 PM
ATI OpenGL is SLOW!! tionik06 Linux - Hardware 7 08-22-2005 10:13 PM
comp hangs -opening applications which uses opengl on xfree864.3 with sis300/305 phoenixgod Linux - Hardware 1 12-11-2004 02:55 PM
Very slow OpenGL mr_rob Linux - Newbie 3 09-24-2003 01:29 PM
slow a$$ opengl e1v!$ Linux - Software 14 07-19-2003 02:15 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 11:59 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration