LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (https://www.linuxquestions.org/questions/linux-general-1/)
-   -   old pc, new kernel; small problem (https://www.linuxquestions.org/questions/linux-general-1/old-pc-new-kernel%3B-small-problem-171370/)

b0uncer 04-17-2004 04:11 PM

old pc, new kernel; small problem
 
I've just bought a new (well, not actually new but newer) pc and got an idea to build up an ethernet of three pcs, just to try it out. Earlier I've only had a chance to build an ethernet in school few years ago, so thought I might need a little practise and so on...anyway, here's what's going on:

The windoze and the linux-win-dualboot box are set ok, and I've tried the ethernet between them (worked fine). Now I'd need to set up the third, oldest pc, too - a problem occurs when trying to install a distro in it. I've got some distro isos burned on cds (a few RedHats, Arch and VectorLinux for example) and I tried to install them - most of them (the newest) installed ok, but at bootup I get the errormsg telling me that something got screwed up while processing the root partition (was it mounting? something like "unable to mount root partition at 0-something-stuff" but can't remember exactly) so that I'm unable to boot the whole thing.

I suspect this is because of the stock kernels that get installed. I'm not sure, but I think some settings in the kernel(s) won't do with the old motherboard and/or processor of the P200MMX, so the newest distribution I've been able to successfully install and boot is RH6...now I thought it's ok, I only get new kernel sources and start updating the thing, but I'm not sure if it works. Any ideas?

The card I'm trying to install is D-Link's normal pci-ethernet card, and the same kind of card works fine on my other linux with 2.6 kernel. If I have time, I'll download the sources and newer tools (RH6's gcc, and perhaps some other things too, is too old, I know :D ) one of these days and try upgrading..but if anyone of you has any other ideas on this ("how to get the card working", "updating the kernel succesfully" or "installing a newer distro succesfully"), I'd be pleased to hear them.

Thanks in advance for any ideas.

AutOPSY 04-17-2004 07:22 PM

well, start by booting the machine to a working kernel, upgrade your gcc to 3.3.3, get module-init tools-3.0, get the 2.6.3 kernel, do make menuconfig, add support for all the peripherals and ext3 filesystem for your older PC, compile, make install, make sure your lilo config is good. and reboot.

Simple really.

If you are using Redhat, a good place to go for any rpm's is http://rpm.pbone.net
there is a search box, you must search for example: linux-2.6.3.tar.bz or module-init-tools*
and links come up for download. it is one of the best places as an rpm-repository.

b0uncer 04-19-2004 09:01 AM

thanks.. especially for the tools/versions I need for this.

b0uncer 04-24-2004 01:19 PM

ok, a bunch of new difficulties appeared...the first of them is, of course, the quite well-known 'dependency-hell'; I downloaded the rpm-packs needed, and tried to install. All I got was some unsatisfied dependencies, which I also tried to search and download - only to get a bunch more of unsatisfied dependencies... In the meantime I tried some other tricks too like installing Gentoo which turned to go just fine (better than any else) until I started to get some %$#%"& I/O-errors from my cd-drive. Damn..anyway, here's the question: do I need to satisfy these dependencies forever (which takes time and my nerves a lot) or is it enough that I force these few rpm's to install without dependency checking (if it's possible), or what? An oh - I guess there's one dependency I need to satisfy before continuing..while trying to upgrade gcc, for example, I got something that gave me the picture that my whole rpm system would be "old"..now I'm not sure about this, but is there a package for RPM itself somewhere? Huh?


All times are GMT -5. The time now is 04:32 PM.