-   Linux - General (
-   -   Old file system discovered after disabling ext4 journaling (

k14 05-07-2011 07:00 PM

Old file system discovered after disabling ext4 journaling
I bought a ssd drive for my laptop, installed it, installed Windows 7, installed Kubuntu 11.04.
Till then everything worked fine, and I had following partitions on my disc:

/dev/sda1 ntfs ~100MB win boot,
/dev/sda2 ntfs ~170GB win main,
/dev/sda3 extended
  /dev/sda5 ext4 / ~50GB
  /dev/sda6 swap ~4GB

Then, due to ssd, I disabled journaling on ext4 with instructions given here:
It was simply:
  • boot from live cd
  • sudo tune2fs -O ^has_journal /dev/sda5
  • sudo e2fsck -f /dev/sda5
It worked fine. While using 11.04 I encountered a serious bug in nvidia 270.41.06, and decided to switch to Kubuntu 10.10. I installed 10.10 on the very same /dev/sda5 (clicking a checkbox to format it). Everything worked fine, grub was installed and pointing to win7, and kubuntu 10.10. I disabled ext4 journaling as above, rebooted, and found, that grub now points to win7 and 11.04, and that system (which should have been removed during installation of 10.10) loads perfectly fine.
I checked where 11.04 had been installed - still /dev/sda5. Win7 loads fine as well, so no linux on /dev/sda2 :) I checked if there was 10.10 kernel in /boot - no. File system on sda5 had no trace of 10.10.

I formatted sda5 with gparted, installed 10.10 again, disabled journaling and situation repeated, whole file system on sda5 changed. Enabling journaling did nothing, 10.10 didn't come back.

I deleted sda3, sda5, sda6, made them again, installed 10.10, disabled journaling, and finally had my 10.10 on ext4 without journaling. So this is kind of solved, but I would still like to know that the hell happend? For the moment it looked like two file systems coexistened on one partition. This is some magic for me. Could somebody explain to me what happend, or just give a link to a page covering this topic?

frankbell 05-07-2011 08:43 PM

It looks like you had an extended partition that contained two logical partitions. This is perfectly okay.

k14 05-08-2011 06:45 AM

Do you mean "extended partition" -> sda3, "two logical partitions" -> sda5, sda6? Then I know it's okay, but it doesn't answer my question.
Or do you mean "extended partition" -> sda5, "two logical partitions" -> sda5, sda5? Then it's weird for me.

To be precise, the question is: why, after disabling journaling on sda5, 10.10 files disappeared, and 11.04 files appeared, even though the latter were earlier formatted?

Update: the problem is back. After i DELETED sda3, sda5 and sda6, made them again, installed 10.10 on sda5, disabled journaling, made a few reboots it looked fine. But today, 11.04 is back again!

Update2: from live cd I did $ sudo dd if=/dev/zero of=/dev/sda5, deleted sda3, sda5 and sda6, made them again 7GB earlier on disc (by shrinking sda2), installed 10.10, rebooted, got some errors, rebooted, got 11.04! Still the very same 11.04, from the very begining. This have to have something to do with SSD maping or ext4 with journaling or both...

Update3: it is not disabling journaling, that travels back in time to 11.04, but making a cold start. After a cold start installation of 10.10 is simply lost.
I booted from live cd, did sudo hdparm -W0 /dev/sda to set write cache off, installed 10.10, did cold restart, and... no change. 11.04 again.

Update4: ok, this is a hardware issue. No changes in files are saved after a cold start on 11.04 nor Win7.

Mod, pls move to hardware.

frankbell 05-08-2011 09:41 PM

I mean sda3 was an extended partition containing sda5 and sda6 as logical partitions.

Regarding why the problem appeared, I have no idea, but I suspect that disabling journaling in a journaled file system had something to do with it.

k14 05-09-2011 04:50 AM

I know what they were because I made them. Many times during this weekend...

When I disabled journaling I probably did cold restart and associated the former with the problem. But I was wrong, this is a disc error, it's now cold dead.
I'm still impressed by my disc, which cached whole partition, as i did dd. It also cached whole 10.10 installation between warm restarts. You can't trust your ssd.

frankbell 05-09-2011 07:37 PM

Oh, so it was giving up the ghost(s) as it were?

k14 05-13-2011 07:36 AM

It actually hanged whole machine, after I upgraded its firmware as suggested on manufacturer forum.

All times are GMT -5. The time now is 12:35 PM.