LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 10-09-2002, 09:05 AM   #1
kabads
Member
 
Registered: Sep 2002
Distribution: Debian
Posts: 69

Rep: Reputation: 15
Ogle (DVD) skips


Just managed to get OGLE running on my sis in law's laptop.

However, it skips when playing. Is this to do with the swap space? Mandrake 9 gave very little space to swap.

The whole thing runs slower than usual, especially in KDE.

Any ideas as to what's making the DVD skip?
 
Old 10-09-2002, 09:08 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975
probably a DMA issue, make sure it's turned on with hdparm, see the man page for more details
 
Old 10-09-2002, 09:28 AM   #3
kabads
Member
 
Registered: Sep 2002
Distribution: Debian
Posts: 69

Original Poster
Rep: Reputation: 15
Thanks ak - I did read about DMA and hdparm, but it frightened the life out of me. What does DMA stand for - and what manual page - the hdparm one? If so, it looks like I don't have it installed, as man hdparm comes back with no manual entry for hdparm.
 
Old 10-09-2002, 09:44 AM   #4
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975
Direct Memory Accessing, what it means is that basically the Processor simply has to set up a direct channel from the dvd drive to other hardware, meaning that the cpu itself doesn't have to manually pull off each little bit of data from the dvd drive itself, which is far too intensive. you really should have hdparm in there somewhere, normally /sbin/hdparm, it's a pretty core utility.
 
Old 10-09-2002, 10:22 AM   #5
KL2001
Member
 
Registered: Sep 2002
Location: MN, USA
Distribution: RedHat 8.0
Posts: 30

Rep: Reputation: 15
I have the same problem, but It won't allow me to turn on DMA....I had the same problem in windows 98, until I got a newer version of power DVD which fixed it... I needed powerDVD XP in windows before I could play DVDs skip free. Any Ideas on how to speed up performance of my drive?

hdparm -Tt output ( same drive, just different links)

/dev/dvd:
Timing buffer-cache reads: 128 MB in 0.94 seconds =136.25 MB/sec
Timing buffered disk reads: read(1048576) returned 16384 bytes

/dev/hdc:
Timing buffer-cache reads: 128 MB in 0.94 seconds =135.97 MB/sec
Timing buffered disk reads: read(1048576) returned 16384 bytes


As you can see, that is VERY PAINFULLY SLOW!!

I'm thinking it might be faster to read a DVD movie off a vinyl.
 
Old 10-09-2002, 12:02 PM   #6
nxny
Member
 
Registered: May 2002
Location: AK - The last frontier.
Distribution: Red Hat 8.0, Slackware 8.1, Knoppix 3.7, Lunar 1.3, Sorcerer
Posts: 771

Rep: Reputation: 30
Quote:
Originally posted by KL2001
I have the same problem, but It won't allow me to turn on DMA.
What is the error you're getting?
 
Old 10-09-2002, 07:52 PM   #7
ddpicard
Member
 
Registered: Oct 2001
Location: Texas
Distribution: Slackware 13
Posts: 214

Rep: Reputation: 31
Ok, I use Ogle also. I had the same problem because I did not have DMA turned on.

To turn DMA, open an xterm:

su - root

and type:

hdparm -d 1 /dev/hdb

Mine is hdb your might be hdc or hdd, all depends where it is connected.

To check if it is turned on you can type:

hdparm /dev/hdb

This will only work until you reboot. You can add the hdparm command to your boot.local script so it will enable DMA during the boot process.

I have SUSE 8.0 and mine is located in /etc/init.d/boot.local
not sure where yours will be.

Hope that helps. Sorry if I did not explain that to good.

ddpicard
 
Old 10-09-2002, 11:59 PM   #8
KL2001
Member
 
Registered: Sep 2002
Location: MN, USA
Distribution: RedHat 8.0
Posts: 30

Rep: Reputation: 15
[root@c24 root]# hdparm -d 1 /dev/hdc

/dev/hdc:
setting using_dma to 1 (on)
HDIO_SET_DMA failed: Operation not permitted
using_dma = 0 (off)
 
Old 10-10-2002, 05:11 AM   #9
kabads
Member
 
Registered: Sep 2002
Distribution: Debian
Posts: 69

Original Poster
Rep: Reputation: 15
Thanks guys - works a treat - is there any way to mount this drive with hdparm at boot up? Basically, I don't want sis typing this in as root every time she wants to watch a DVD.

Is there something I need to put in /etc/fstab?
 
Old 10-10-2002, 09:40 AM   #10
ddpicard
Member
 
Registered: Oct 2001
Location: Texas
Distribution: Slackware 13
Posts: 214

Rep: Reputation: 31
As I said in my above post:

"This will only work until you reboot. You can add the hdparm command to your boot.local script so it will enable DMA during the boot process.

I have SUSE 8.0 and mine is located in /etc/init.d/boot.local
not sure where yours will be."

This worked for me. I'm no Guru by any means so you may have to add it to some other script. The info I found on the net said to add to the boot.local script.

ddpicard
 
Old 10-10-2002, 09:44 AM   #11
Smitty-rh
Member
 
Registered: Oct 2002
Distribution: Redhat
Posts: 35

Rep: Reputation: 15
KL2001
from the release notes:

DMA is disabled on CD-ROM drives in this release in a different but more reliable way than
previously. If you are sure that your CD-ROM drive is capable of IDE DMA, place the following
line in the /etc/modules.conf

options ide-cd dma=1

you will then be able to turn DMA on for your cd using hdparm -d 1 /dev/hdc

as long as your cdrom is hdc



kabads

create this file /etc/sysconfig/harddiskhdX where X = your drive ie hdc hdb etc.

enter this line in that file

USE_DMA=1

this will allow you to hdparm -d 1 one time and then dma for the drive will be active on boot.
 
Old 10-10-2002, 09:45 AM   #12
kabads
Member
 
Registered: Sep 2002
Distribution: Debian
Posts: 69

Original Poster
Rep: Reputation: 15
D'oh! Sorry - yep - boot.local.

Funny thing is, it worked for me without a reboot - one minute a jerky DVD the next it was fine.
 
Old 10-11-2002, 08:38 AM   #13
KL2001
Member
 
Registered: Sep 2002
Location: MN, USA
Distribution: RedHat 8.0
Posts: 30

Rep: Reputation: 15
Tuens out all I needed to do was turn on SCSI emulation, I completely forgot that I hadn;t done that yet...but one line added to grub.conf, and I'm runing good in both ogle and mplayer.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
DVD Video skips in certian players niztec Linux - General 0 08-08-2005 02:32 PM
ogle dvd player DAChristen29 Linux - Software 8 03-21-2003 02:25 PM
OGLE DVD player Crashed_Again Linux - Software 4 02-17-2003 05:09 AM
Ogle DVD problems Archon Linux - Newbie 4 06-13-2002 09:28 AM
ogle dvd rain_maker Linux - General 0 03-07-2002 01:42 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 04:20 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration