-   Linux - General (
-   -   Nvidia Geforce4 - NO GLX!!!! (

pteren 01-12-2004 05:56 AM

Nvidia Geforce4 - NO GLX!!!!
Can anyone help?

I installed the nvidia driver for my card. At least I think it is the right one!!! I went for the ia32 unified driver and am running AMD athlon 2000XP.

Is this the correct one? I'm not sure what exactly is meant by ia32/ia64?

Anyhow it loads the module (checked in XFree86 log file) and I made the appropiate corrections to the XFree86.conf such as removing load dri and load glxcore and replacing them with the nvidia options - as detailed in their readme.

However still no GLX. KDE gives a option to set up the display in one of its options. In the gui there is a clickable button to enable 3d acceleration but it is ghosted out!?

schatoor 01-12-2004 06:37 AM

What version of the driver are you using? Problems have been reported with the very newest driver. Download an older one and see how that goes.

Peteatwork 01-23-2004 10:30 AM

I just jumped through a bunch of hoops getting this to work on my Suse 9 install, so I hope this applies to you too..
I found another post on this forum that outlined exactly what you need to do to get it to work (sorry, I couldn't find it to provide a link for you). I would recommend backing up your original XF86Config file before trying any of this though to be safe.

As root I had to:
Open XF86Config file with a text editor
Locate the "Device" section
Change the driver= from "nv" to "Nvidia"
Save XF86Config
It all worked fine for me after that.

The other post also suggested running glxgears from a console to test the driver. I did, and got 5768fps with the new driver.

pteren 02-02-2004 03:47 PM

Cheers schatoor - that's got it - I had downloaded the newest one and so just reinstalling the module with of a slightly older vintage seems to have done the trick.

Thanks again

All times are GMT -5. The time now is 10:59 AM.