-   Linux - General (
-   -   Nvidia drivers on AMD64 (

Ruzhyo 08-13-2004 06:51 PM

Nvidia drivers on AMD64
I'm having trouble installing nvidia drivers on my AMD64 machine - I've just installed slackware 10.0, and then downloaded the 2.6.7 kernel sources. I got crosstoools so I could compile a x86_64 kernel from my 32 bit (emulated) 2.4 kernel - rebooted, and finally got that all working fine with the ARCH and CROSS_COMPILE flags and such.

But then I downloaded the latest AMD64 nvidia driver for my 5700 Ultra (Version: 1.0-6111). As root, I run:

sh ./

and I get:

Verifying archive integrity... OK
Uncompressing NVIDIA Accelerated Graphics Driver for Linux-x86_64 1.0-6111........................................................................
./ line 615: ./nvidia-installer: No such file or directory

I tried the -x (extract only) option, and then changed to that directory and ran ./nvidia-installer to get the same error. I made quadruple sure I didn't mistype or something, even redownloaded the file again - I have no idea what's going on.

I had this same card running in slack 10.0 on the 2.6.7 kernel on a 32 bit processor, so I don't think it's a slackware problem, but a 64 bit linux problem. Could it have something to do with the default gcc compiler being set up for 32 bit? I've set the symbolic link correctly for /usr/src/linux,, etc. I've googled until my fingers are numb but haven't found anything that works or is helpful.

Any thoughts or ideas?

spuzzzzzzz 08-15-2004 06:42 PM

You're trying to run a 64-bit program (the installer) on a machine with 32-bit libs. My guess would be that it is unable to find the correct glibc libs to load.

Ruzhyo 08-16-2004 04:56 PM

Yeah, I kind of figured it was something along those lines, but wasn't sure how to fix it. I ended up just installing the x86_64 version of fedora core 2. But because I have the 64 bit version of fedora installed, when I want to build things from source, can I still just do "./configure; make; make install" and it is in "64-bit mode" or do I have to change some variables or compile flags somewhere to keep it from building in 32 bit mode and running emulated? I figure that since I have a 64 bit proc, I might as well make use of it, but wasn't sure if it would do that by default. thanks

spuzzzzzzz 08-16-2004 05:19 PM

I've never used Fedora 64-bit but it probably installs a 64-bit compiler. In that case ./configure make make install should give you 64-bit binaries. The way to check is to look at the first couple lines of the ./configure output. If it mentions x86_64-pc-linux-gnu, then it's compiling for 64-bit. If it mentions i686-pc-linux-gnu, it's only doing 32-bit.

Ruzhyo 08-16-2004 06:11 PM

Ok, thanks. By the way, do you have 64 bit gentoo running, by chance? I had a stage 1 gentoo on my old machine, but wanted to give 64 bit gentoo a try - anything special I should know before jumping in? I appreciate your help - I've done a fair amout of linux but this 64 bit stuff is new to me :)

spuzzzzzzz 08-17-2004 05:08 AM

It's kinda new to me too :) I got my Opteron box a couple weeks ago and I've been running gentoo on it since. So yes, I am running 64-bit gentoo but I'm not very experienced with it yet. So far, it's all worked pretty well. The only downsides are that I can't use flash easily (since Macromedia only provides 32-bit binaries) and there aren't as many packages available. In a pinch, you can set ACCEPT_KEYWORDS to x86 or ~x86 and try to install a non-amd64 approved package. I've done it sucessfully a couple of times (only on small packages, though) but it probably isn't recommended.

All times are GMT -5. The time now is 02:14 PM.