Visit Jeremy's Blog.
Go Back > Forums > Linux Forums > Linux - General
User Name
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.


  Search this Thread
Old 02-24-2003, 04:00 AM   #1
LQ Newbie
Registered: Feb 2003
Posts: 1

Rep: Reputation: 0
Not able to connect from Remote Machine.

Hi All,

I am a novice to Linux .

I have configured a Linux system. When I am login from the same Machine/server I am not facing any problem. When I am trying to connect Machine/Server from a different machine it says
Login Incorrect.

Services, I have selected rlogin. Please let me know what are the things I have to do to connect (using telnet) to the server.

Old 02-24-2003, 05:45 AM   #2
Registered: Feb 2003
Location: Helsingborg, Sweden
Distribution: Slackware
Posts: 52

Rep: Reputation: 16
Is the username you're trying root?

I believe default installations of lots of linuxes don't allow remote root logins. Try a standard username and use su for root.
Old 02-24-2003, 06:12 AM   #3
Registered: Dec 2002
Location: California
Distribution: Slackware & LFS
Posts: 799

Rep: Reputation: 33
You should disable rlogin. It has nothing to do with telnet. It is an old BSD protocol that is not necessary in Linux. While you're at it, you should disable rexec and rsh, since these also aren't necessary. Generally, from a security standpoint, you should disable any services that aren't necessary, as they only provide more opportunitites for badguys to hack into your system.

Of course, if you're at all interested in keeping your system secure, you'll also disable telnet and use ssh instead.

But if you insist on using telnet, you must make sure that it is enabled. Start by running the command "netstat -ta". You should see telnet listed on a line ending with "LISTEN". If you don't see this, try looking in the /etc/inetd.conf file. Look for a telnet entry, and make sure that is uncommented.
Then, as the comment in the slackware version says: If you make changes to this file, either reboot your machine or send the inetd a HUP signal:

Do a "ps x" as root and look up the pid of inetd. Then do a "kill -HUP <pid of inetd>".
The inetd will re-read this file whenever it gets that signal.

--- Cerbere

Last edited by Cerbere; 02-24-2003 at 06:16 AM.
Old 02-05-2004, 06:14 PM   #4
LQ Newbie
Registered: Feb 2004
Posts: 8

Rep: Reputation: 0
You have to edit /etc/securetty and uncomment out the tty and pty entries
to allow root to login remotely. Its like to old sunos.

I am still having trouble getting root login to not ask for passwd.
I have .rhost , inetd login -f and nothing works.
Anyone know what I am missing.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't SSH to remote machine: Connection closed by remote host Avatar Linux - Networking 35 10-23-2017 01:21 AM
scp: copy a file from local machine to remote machine seran Linux - Newbie 8 10-30-2007 01:23 PM
how to open a dilog on local machine when i do ssh to remote machine fahad26 Programming 3 05-03-2005 08:39 PM
How to Connect to Remote Red Hat 9 Machine Via Internet? shelldinesh Linux - General 3 10-06-2004 01:13 PM
using linux to redirect remote vpn traffic to another remote machine brb5548 Linux - Networking 0 06-28-2003 10:07 PM > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 11:54 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration