-   Linux - General (
-   -   No SWAP but all RAM!! (

hari_seldon99 01-13-2004 06:31 AM

No SWAP but all RAM!!

I just bought a gateway 310x desktop with 256mb RAM and run a dual boot with MDK 9.2 & WinXP. According to the 2x-for-less-than-512mb convention, I made a 512 mb swap partition. I ran top and saw that the swap space is barely used and almost ALL my RAM is being used. My swap space is on sector 16. This happens even when I'm doing nothing but run the X-server and the various services and daemons and things that load up at boot (I'm not running anything more than the usual stuff: APM, saslauthd, blahblah, and the giFT p2p daemon)

output of top right now:

Cpu(s): 0.7% user, 0.7% system, 0.0% nice, 98.7% idle
Mem: 246920k total, 242604k used, 4316k free, 11676k buffers
Swap: 530104k total, 24k used, 530080k free, 100752k cached

The reason why I find this wierd despite all that is said in the posts above is that I used to use an IBM Thinkpad 770Z until I hosed it's motherboard. I ran Linux MDK 9.1 there. It had 192Mb RAM and I put 400Mb of swap space (it was in a higher sector). Then, it used only about 1/3rd of my RAM while not doing anything other than the background stuff and seemed to adequately manage the RAM/swap allocation whenever the load got high.

This is why I am wondering if I have misconfigured my installation. IS the swap space inaccessible for some reason? Does it matter? Pleas let me know if I should do anything.


kilgoretrout 01-13-2004 06:45 AM

It's normal. Most of the ram is being used for cache. Nothing to worry about. Try running:

$ free -m

Here's my output to give you an idea:

[patrick@localhost patrick]$ free -m
total used free shared buffers cached
Mem: 755 745 10 0 45 429
-/+ buffers/cache: 271 484
Swap: 1741 0 1741

ac1980 01-13-2004 07:10 AM

Look at the buffers and cache, at the end of the lines: you have 210+MB ready to be freed on demand.

yanik 01-13-2004 10:48 AM

THe system uses the ram before going into your swap partition. ram is much faster.

All times are GMT -5. The time now is 01:20 PM.