-   Linux - General (
-   -   "no space left on device", but there is! (

drowstar 10-09-2004 05:43 AM

"no space left on device", but there is!
Hello guys (and girls),
I feel a little stupid having to ask this, but I really (really!) can't make sense of it:

Last night I started a large download and went to sleep.
When I started the computer today it would not start X. Turns out I had it save the download to my system partition, which was consequently completely full and caused all kinds of weird behavior.
I deleted the downloaded files and rebooted. Weird thing was the error was still there.
`df -h` reports a total size of 9.7G (correct) of which 9.4 are full. However it says that there is 0 space available.
A file I created with `cat /dev/urandom >> somefile` was 231M when it ran out of disk space (that was before I deleted a few more files, which didnt make much difference).

Still pretty much any program I try to start (at least the GUI based ones (I can get the x-server to run using the vesa driver)) fails with a "no space left on device" error.

What to do?

Thanks for all replies,
- drowstar

hob 10-09-2004 10:21 AM

I've heard that approx. 10% of disk space is reserved for files owned by root, so it is expected that there is a mismatch between the amount of free space reported and the amount that is actually available. But I've never filled a partition to find out...

michaelk 10-09-2004 11:36 AM

Actually the default is 5%. You can use the tune2fs command to reduce the amount of reserved space but you do not want a value of zero. It looks like its time to clean up or migrate to a bigger partition

btmiller 10-09-2004 02:09 PM

Also, there's an off chance that you might be out of inodes on the filesystem -- do df -i to see inode usage. This is probably not the case, but it doesn't hurt to check.

drowstar 10-10-2004 04:44 AM

Thanks a lot for the information guys!
There was in fact less than 5% disk space available, so I assume that was the reason. I have not tried freeing up more space though. I dont think I am going to either. The system never worked very well anyways, so I think I'll just install another distro this time around.

Thanks again,
- drowstar

All times are GMT -5. The time now is 06:48 AM.