LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (https://www.linuxquestions.org/questions/linux-general-1/)
-   -   no sound w/ soundblaster live (https://www.linuxquestions.org/questions/linux-general-1/no-sound-w-soundblaster-live-3756/)

jiplen 06-27-2001 05:04 PM

no sound w/ soundblaster live
 
Hello,
I'm having a problem with my sound card, I'm running a Gateway 1.4 athlon, 256 ram, geforce 3, soundblaster live value, and a wierd 56k modem/ homenetworking card w/ windows me and redhat 7.1 dual booting.

When i installed redhat, I had a problem w/ the driver for the geforce 3, but since the nvidia driver is the same on their website (I think) I used the geforce 2 driver and got the card to work. (I don't know if that's relevent or not)
When I tried to configure the sound card in sndconfig, the program found it, but when sndconfig played the audio sample, no sound came out (no error either). I've tried to install the newest driver from creative, but both drivers are the same, or very close to it and it didn't change a thing. If I go in as root and try to pipe something to /dev/dsp, /dev/dsp1, or /dev/dsp56 I get an access denied message. I can't open /dev/sndstat with pico, I get an error "file does not exist' or something to that effect.

I checked modules.conf and found the driver in there with some pre-install and postinstall configurations with aumix after it. I can get the actual configuration if anyone needs it, I'm not at my computer right now, so I can't open the file.

Finally, if I play a sound file in xmms, gnome, or a cd player, nothing come out of the speakers, but I get no errors.

Sorry for the long post, but if anyone could help me I would really apreciate it.

Thanks in advance,
Jason

jrmann1999 06-27-2001 06:38 PM

/dev/sndstat no longer exists in the 2.4.x kernels so that's not an actual issue.

When you examine your kernel loading, or load the module for your soundcard explicitly, does it work fine? IF you don't know how to look at your kernel boot, just do:

# dmesg | more

and it'll allow you to see everything that happened during bootup.

My last question is, have you unmuted the audio channel with some sort of mixer? It sounds obvious but some people forget it, it's mostly a problem with alsa drivers, but since you didn't specify which you were using I thought I'd ask.

Oh yeah, if you don't even have a /dev/dsp(like it's just not there) then you need to go into dev and do a:

# ./MAKEDEV -v audio

which will make all of your audio devices,

Hope this helps.

J

jiplen 06-27-2001 09:22 PM

Hi j,

well, I took you advice and looked in the boot messages, the modules (EMU10K1) loads fine, it assigns it irq 9. I actually have /dev/dsp, but everytime I try to pipe something in, I get a permisions denied even though I'm running as root. The mixer is set as high as I can in the gui interface and in the aumix text interface, it is set high also. In a gui volume meter, it displays the sound, so the driver works and is sending input to the mixer. I looked in modules.conf and this is what I found

alias eth0 tulip
alias parport_lowlevel parport_pc
alias sound-slot-0 emu10k1
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1 || :
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 || :
alias usb-controller usb-uhci

I've never played w/ this stuff before, but piping something into /dev/null doesn't seem right

could you guys give me anymore advice?
Jason

jrmann1999 06-27-2001 10:17 PM

The /dev/null reference is just piping any output to the /dev/null device(effectively ignoring it with force).

Post for me(if you would) the output of:

# lsmod

J

jiplen 06-27-2001 11:16 PM

J,

Here's the output from lsmod

Module Size Used by
sr_mod 15264 0 (autoclean)
emu10k1 49632 0 (autoclean)
soundcore 4464 4 (autoclean) [emu10k1]
autofs 11264 1 (autoclean)
tulip 38544 0 (autoclean) (unused)
ipchains 38976 0 (unused)
ide-scsi 8352 0
scsi_mod 95104 2 [sr_mod ide-scsi]
ide-cd 26848 0
cdrom 27232 0 [sr_mod ide-cd]
nls_iso8859-1 2880 1 (autoclean)
nls_cp437 4384 1 (autoclean)
vfat 9392 1 (autoclean)
fat 32672 0 (autoclean) [vfat]
mousedev 4160 1
hid 11776 0 (unused)
input 3488 0 [mousedev hid]
usb-uhci 20720 0 (unused)
usbcore 49664 1 [hid usb-uhci]


I heard something about soundcore needing to be loaded before emu10k1, could that be why emu10k isn't used?
Jason

jrmann1999 06-27-2001 11:24 PM

emu10k1 will never show a used status b/c no module after it will ever use it. You've reached the limit of my help. I wish you luck.

J

jiplen 06-28-2001 08:34 AM

Well, Thanks alot for your help J,

if anyone could give me some advice I'd really apreciate it.
I still think that piping the output of aumix into /dev/null doesn't seem right, so I'm going to try piping it to /dev/dsp or to the screen, and see what happens

Jason

jiplen 06-28-2001 04:14 PM

okay, so I've tried changing the piping on the modules.conf file with no sucess, I also tried
#cat /etc/modules.conf | /dev/dsp
and I get an access denied message. Is that supposed to happen? Am I using the | when I should be using > ?

Any help would be greatly appreiciated
Jason

DavidPhillips 06-28-2001 11:38 PM

See if IRQ and DMA is the same for the card in windows as it is in Linux.

when you run sndconfig you should answer no to "did you hear sound" to configure it.

jiplen 07-03-2001 11:55 AM

Hello everyone,

I finally got the soundcard to work, sort of. THis is how I did it:

I downloaded the newest drivers from http://opensource.creative.com. Then I unpacked the tar file and compiled the driver, and installed it. Then I compiled the mixer included and installed it, then I messed with the script until sound worked, if anyone needs help with this email me and I'll tell you exactly what I did.


All times are GMT -5. The time now is 11:18 AM.