-   Linux - General (
-   -   No output through SPDIf, but analog works. How do I get output through SPDIF? (

seanwnz 12-11-2004 08:55 AM

No output through SPDIf, but analog works. How do I get output through SPDIF?
Hi everyone -

I have a Gigabyte 7VAXP mobo.
The audio chipset is an onboard VIA 8235.
I am running Debian and Linux2.6.8.

ALSA 1.0.7 (latest vesion) is all set up, but some config file is obviously not set to allow optical or coax sound output.

Any help greatly appreciated. :) If you need more info I don't mind dumping it in here.


MasterC 12-12-2004 02:50 AM

Wow, I just conquered this feat like 2 weeks ago. Check the settings on "IEC958 Playback AC97-SPSA" and be sure it's set to volume level '0'. The different levels are outlined on the alsa wiki, but basically 0 is the necessary level to get S/PDIF output. The volume isn't what is actually being adjusted, although that's what is thought.

A side bit of knowledge that I found in my trek for information on this:
S/PDIF stands for:
Sony/Panasonic Digital Interface
Crazy eh?



seanwnz 12-12-2004 10:03 AM

Thanks MasterC,

Unfortunately that did not solve the problem - there is still nothing coming through.
Although I'm sure that would have inhibited it once I solved the _other_ problems. :-)

What do you think I should check next?
The mobo is definitely communicating with my stereo in digital (you can tell), but there is no actual audio coming through.
I have the things in volume control unmuted.


babyface 11-25-2005 06:41 PM

It's fucking amazziiinnnngg. And stupid at the same time. Tried for hours to solve pb by updating many thing and looking on hundreds of forum.
I don't know if it works a lot but for me just fine, I explain :
I have Asus with SPDIF out on a intel ICH5 (intel8x0) sound chip. Mandriva 2005 installed. I had sound in totem but only for AC3 signal.
But no other sound, not in gnome for events, not in xmms and not even in totem with regular PCM sound.
Seam to work find in players but no sound on the amplifier.
Then I just read some guy says to set slider from digital to 0. So I go to GNOME ALSA mixer and set le IEC958P slider to 0 (not really beleving it will do any good). And I close the panel and hear a sound. Think I dreamed it. AND NO ! THERE SOUND !!!


So pass this info 'cause it won't solve always this pb for everybody but cost only 2 sec so just give it a try.

ceasol 12-24-2005 01:12 PM

Babyface I had the same problem, I was using de ALSA Mixer GUI in my SuSE 10 and IEC958 sliders were stuck, so I change to kmixer put 0 in IEC958 Playback and BINGO!!! I got sound via S/PDIF!!!!


TZRick 09-02-2006 12:05 AM

I'm a bit of a newbie here, and I am experiencing the same problem: no sound through SPDIF. I am not sure I understand the suggestions that were being made. I use Gnome, so I don't have the KDE mixer. As for the Gnome mixer, I am assuming you mean gamix? I have gamix, qamix, ALSA mixer gui, Envy24Control (doesn't seem to do anything), HDSP mixer, RMEDigiControl ("No RME Digi Soundcard found"), Volume Control and VOlume Monitor.

As for hardware, I am using the old SoundBlaster Live! Value with digital output. I just migrated from Windows Millenium and had no problem there getting digital output from WinDVD.

Any suggestions?

I certainly would appreciate any help I can get. This is driving me nuts!

RobAnt 12-01-2006 07:37 AM

I also am using a SB Live! card. The answer is:

Multimedia/Volume Control/Kmix (Sound Mixer) - it should be automatically installed, I believe.

Then in Kmix - Switches Tab and ensure there is a little light in SB Live Analog/Digital. If no, click on it - this puts the card in digital only mode, I believe.

As soon as I made the switch, Amarok started to work, and I immediately surfed to BBC Radio 2 website,clicked on Listen Live and immediate success. Best I've heard, in fact (well, digital that is).


TZRick 12-02-2006 01:35 AM

Thank you for the response RobAnt. I've had so many things to take care of with OpenSUSE that I simply switched to Ubuntu and 100% of issues that I had have been resolved with far less effort than it took to research and experiment with OpenSUSE...and still not get anywhere.

RobAnt 12-03-2006 05:22 AM

No problem - the answer stands here for others with the same problem.

I have found a mixer needs to be installed. I installed ALSA, which provided the mixer. Without a mixer, kmix doesn't present the required tab.

TZRick 12-05-2006 05:31 AM

Actually, my problem related to playing SPDIF for DVD through Xine. With Ubuntu, I just had to select SPDIF pass-through in Xine and it worked. I'm not sure if I had tried that or not in OpenSUSE right before I switched. Also, I had used the ALSA mixer without much luck.

scottwww 12-19-2006 10:35 PM

This post put me on the right track. I'm running SuSE Linx 10.0 on an ASUS A8N-SLI Deluxe. This mobo has the Realtek ALC850. I plug my audio in through digital coax to my speakers. Yesterday I got the drivers setup correctly, and all looked like it was working. I just couldn't hear it. So, I plugged headphones into the analog output and there was sound. I wanted to use my existing digital connection to my speakers so I found this thread. I looked for IEC958 in each of the volume controls. I couldn't get any of them to give me sound until I opened gamix. Gamix has IEC958 with a drop down list. Just to the right is Playback with a slider. I dragged the slider to the left and clicked the little white box under it. Voila! Just what I needed. Many thanks!

brundles 11-08-2007 12:24 PM

For those running Gutsy Gibbon who haven't had any luck, try going through the following:
Systems -> Preferences -> Sounds

Then under the Default Mixer Tracks portion set the device to the digital device (in our case HDA Intel (Alsa Mixer)) then scroll down and click IEC958 from the list. You then need to increase the volume for IEC958 playback (i.e. the opposite of that posted here).

Works for me!

All times are GMT -5. The time now is 09:47 AM.