LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 12-13-2008, 11:19 PM   #1
moman0791
LQ Newbie
 
Registered: Dec 2008
Location: Kansas
Distribution: 8.04 Hardy Herion
Posts: 3

Rep: Reputation: 0
No foreground sound when played from hard drive ripped dvd with k9copy XP playback OK


I am not sure where to look or where to ask to solve this problem. It doesn't appear to be in my sound settings. There is very low volume dialog when playing a vob from hard drive, but the back ground sound is there - in fact it's louder than the dialog - no matter which player I use in Ubuntu. When I burn the files to disk I can play it through any number of players in Ubuntu just fine. It is also OK when played in XP from a file.

Perplexed....
 
Old 12-14-2008, 12:34 AM   #2
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
Do you use the Xine or gstreamer versions of your players.
Have you tried converting the vobs to ogg/theora and playing that?

Do you author the vobs into a dvd or play them as files stored on a data dvd - to get clear playback?
 
Old 12-14-2008, 04:48 AM   #3
htnakirs
Member
 
Registered: Mar 2007
Posts: 239

Rep: Reputation: 34
I think it may have something to do with the number of audio channels. Can you check if the player is selectively playing any channels, instead of all of them? Probably the volume of a particular channel is turned down?
 
Old 12-14-2008, 04:42 PM   #4
moman0791
LQ Newbie
 
Registered: Dec 2008
Location: Kansas
Distribution: 8.04 Hardy Herion
Posts: 3

Original Poster
Rep: Reputation: 0
I use Xine. If I burn the file to dvd it works fine under Ubuntu. If I try to play the file form hard drive in Xine, VLC, Kaffine, Mplayer... in an Ubuntu environment I have this problem. I can play it with no problems from file in Windows. I have checked the volume control and everything is up that should be unless there is a second set of controls in Xine... this should not be the problem. I can't see how converting to ogg will help me here as these players should play these files correctly without the need for a work around, so since I can work around it already, I'd rather resolve the problem.
 
Old 12-14-2008, 05:09 PM   #5
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
Converting to ogg may help - to play the vob requires using non-free software. There are periodic issues with this due to the lack of licensing for linux, DRM etc. Converters seem able to get around this, though they may break the law in some jurisdictions. (MS sells you a license with Windows - but only for Windows.)

In my machine I am unable to play the sound on an mpeg video, I have to transcode to ogg/theora and the file plays fine.

"should" is a loaded word - technically, you should not have to play restricted formats at all. See what I mean?

There is usually a second set of controls hidden in the volume control. Have you checked those - they are often responsible for odd sound issues.

VLC/Xine also has it's own volume control configuration - so it's worth checking that. You can also tweak the decoding parameters in Mplayer.

Being able to play a file in one media fine and not in another is odd. You can play the DVD as a DVD, you can play the Vob off a CD, without this effect.

AFAIK: The difference is in the fs and the driver - the io stream from an OptDD is treated differently. The usual test is still to see if using a free codec works better. It is not surprising that all players are equally affected - all those players are using ffmpeg to play the files.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
No foreground sound when played from hard drive ripped dvd with k9copy XP playback OK moman0791 Linux - Newbie 1 12-14-2008 09:14 AM
No sound on DVD playback, but all other sound works? rps63ifid Debian 3 06-23-2007 01:26 PM
DVD sound playback fatenabu Linux - Software 1 09-10-2005 02:45 AM
Sound and DVD playback on SUSE 9 Facekhan Linux - Newbie 1 01-21-2004 01:36 PM
DTS sound in DVD playback krissly1 Linux - Software 1 11-28-2003 08:39 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 06:06 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration