LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 09-12-2008, 02:12 PM   #1
ciphyre
Member
 
Registered: Aug 2008
Distribution: FEDORA, RHEL, SLES
Posts: 51

Rep: Reputation: 15
No DISPLAY variable when connecting via SSH


I am trying to forward X applications to my local X server using SecureCRT. When I connect to one of my servers using SSH the DISPLAY variable is not being set or is not set. Not sure why this is since all I setup 5 servers at the same time and none of the other four are having this issue.

If I set the DISPLAY manually I am still unable to forward any X apps, I get "Error: Can't open display: locahost:10.0"

Any idea why this variable is not set when I connect and why it still fails when I set it manually?

Thanks,

David

Last edited by ciphyre; 09-12-2008 at 02:14 PM.
 
Old 09-12-2008, 02:17 PM   #2
CRC123
Member
 
Registered: Aug 2008
Distribution: opensuse, RHEL
Posts: 374
Blog Entries: 1

Rep: Reputation: 32
What is the command you're running?

are you sure your including the '-X' option?

Code:
ssh -X user@host
 
Old 09-12-2008, 02:33 PM   #3
ciphyre
Member
 
Registered: Aug 2008
Distribution: FEDORA, RHEL, SLES
Posts: 51

Original Poster
Rep: Reputation: 15
Well your question helped me find the answer..............

I am using SecureCRT to setup the tunnel and it wasn't configured to request X11 packets be forwarded once the tunnel was established. Had I been using SSH from another Linux box I would not have had this issue!!!!

Thanks for asking the right question!!!!

David
 
Old 09-12-2008, 02:36 PM   #4
CRC123
Member
 
Registered: Aug 2008
Distribution: opensuse, RHEL
Posts: 374
Blog Entries: 1

Rep: Reputation: 32
lol. haha
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
SSH not setting Display variable lapope Linux - General 5 09-01-2008 01:46 PM
what's the usage of variable DISPLAY? hongxing Linux - Software 3 12-02-2005 11:31 PM
Problem withChanging DISPLAY environment variable to display on someone else's screen wantsri Linux - Networking 1 10-25-2005 11:14 AM
Tcl Error no display name and no DISPLAY environment variable thinkgeek Programming 5 07-06-2005 10:24 PM
set DISPLAY variable W1pEout[64] Linux - Software 4 01-07-2004 09:41 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 12:18 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration