-   Linux - General (
-   -   NFS mount in /etc/fstab ? (

cozye 12-08-2003 04:35 PM

NFS mount in /etc/fstab ?
I have a server running RH 8. This server has some backup sripts that copy some stuff out to an NFS share on a Unix machine. I have added the NFS mount point to /etc/fstab and it does not mount on startup. Anyone know why ?

If I do a mount -a it will mount
If I put mount -a in rc.local it will mount
All network service startup as usual, netfs is S25. DNS etc.. all works ok.

Any ideas ?

trickykid 12-08-2003 04:50 PM

Can you give us or post what you put in your fstab file to mount the NFS? We don't know or can't guess what's wrong. Any error messages?

cozye 12-08-2003 05:01 PM

saptst01:/sci /mnt/sci nfs rw,soft,bg,intr 0 0

no error messages in startup. It just doesn't mount.
I assume the syntax works fine because a plain 'mount -a' will mount it.

Garlic Overtone 09-12-2014 04:48 PM

Apologies for bumping this, but I had the exact same problem just a few minutes ago, and I solved it.

As it turns out, on this system (RHEL 6.4, for the curious), /mnt was a symlink to /var/mnt. So when I made a mountmount in what I thought was /mnt/derp, and then tried to execute

mount /mnt/derp
, I got this error.

Once I modified /etc/fstab to change /mnt/derp to /var/mnt/derp, I was able to get it working.

mount -a
also worked. I do not know why.

Apologies for the thread necromancy, but since this thread was the first link in a duckduckgo search, I felt I should contribute a solution.

TL;DR: check readlink to be sure your mountpoint is where you think it is.. :)

All times are GMT -5. The time now is 05:39 PM.