LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 06-10-2003, 06:11 PM   #1
jwyant
LQ Newbie
 
Registered: Jun 2003
Location: Atlanta
Distribution: RH9.0
Posts: 25

Rep: Reputation: 15
Newbie.....needing some help...


Ok...so i got RH9 up and running flawlessly.....pretty simple install to be honest...but now it seems this is were the "Fun" starts...

I am majorly confused on the following items:

1. Shell prompt.....I understand how to get to a DOS prompt in Windows.....have no idea here.

2. I cant get my system to surf the web. DHCP is running on a Win2K Server...but the system is not pulling any info! I tried setting it up on a static address but still nothing.

Well i guess we can start with these.....I have tons of questions...but if I can get on the internet, I can view all the docs on the ne RH9 system, and not have to go between my XP machine and my linux box!!!

TIA!
 
Old 06-10-2003, 06:20 PM   #2
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 60
A couple of suggestions. One post, one question, and a subject that is specific to that question. I have to spend my time seeing that someone asked more than one question, and I spend more time editing than giving answers (slow dialup).

Quote:
1. Shell prompt.....I understand how to get to a DOS prompt in Windows.....have no idea here
Open an x terminal or press ctrl-alt-F3 (can be F1 through F6, F7 is the X session)

Using a Windows box to serve Linux. Something sounds backwards here. Does your nose run and your feet smell?

Here is the Redhat 9.0 Network Configuration documentation. HTH

# Redhat links
RedHat Linux Manuals
Maximum RPM
rpmfind
Easier software management: apt4rpm - Red Carpet
RedHat 8.0 Tips & Tricks

# Redhat 7.3 down configuration commands
setup leads to several configuration tools

# Redhat 7.3 up configuration commands
Configure soundcard:
redhat-config-soundcard
Configure X server:
redhat-config-xfree86
Configure network:
redhat-config-network

Last edited by fancypiper; 06-10-2003 at 06:27 PM.
 
Old 06-10-2003, 06:27 PM   #3
jwyant
LQ Newbie
 
Registered: Jun 2003
Location: Atlanta
Distribution: RH9.0
Posts: 25

Original Poster
Rep: Reputation: 15
Well..i have 30 WinX machine here in my corporate office....so windows rules but the numbers....

I went back and re-created a new connection, and now the device wont get out of inactive status....
 
Old 06-10-2003, 06:29 PM   #4
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 60
Gotta get you working then, so you can make a server to protect those vulnerable networked OS which was never designed for secure networking. You may be about to lose it all at any moment. I see your problem now.

Try taking it down and bringing it back up

ifdown eth0
ifup eth0

(I think)

Last edited by fancypiper; 06-10-2003 at 06:35 PM.
 
Old 06-10-2003, 06:34 PM   #5
jwyant
LQ Newbie
 
Registered: Jun 2003
Location: Atlanta
Distribution: RH9.0
Posts: 25

Original Poster
Rep: Reputation: 15
nope......

nothing.

I am restarting the computer....still i can not get it be ACTIVE!

I am duplicating the settings (ip, DNS, subn, etc) of a win machine that works....
 
Old 06-10-2003, 06:40 PM   #6
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 60
I think when I installed Redhat 9.0 (I reverted back to 7.3 as I found it buggy and didn't want to take the time to fix it) I saw nautilus start up with a "start here" that had some sort of networking wizard that may be easier to use, but I am used to my hand configuring. I don't have your version installed and your network, so I can's give specific settings, etc. Redhat changed it too much and removed lots of command line tools in 9.0 that I like to use with 7.3.

Browse through that "start here" and see if you may find the settings easier to configure that way.

Last edited by fancypiper; 06-10-2003 at 06:42 PM.
 
Old 06-10-2003, 06:44 PM   #7
jwyant
LQ Newbie
 
Registered: Jun 2003
Location: Atlanta
Distribution: RH9.0
Posts: 25

Original Poster
Rep: Reputation: 15
well..i got it activated......yea!

not for the surfing part....

If it does not browse the web....and its activate...what areas should i look into?
 
Old 06-10-2003, 07:07 PM   #8
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 60
Windows doesn't do the nameserving?

Try putting your ISPs dns numbers in /etc/resolv.conf Here is my file for a reference:
Code:
domain infoave.net
nameserver 206.74.254.2
nameserver 204.116.57.2
You might put the Windows server IP in as well if it is running a nameserver.

Last edited by fancypiper; 06-10-2003 at 07:09 PM.
 
Old 06-11-2003, 10:07 AM   #9
jwyant
LQ Newbie
 
Registered: Jun 2003
Location: Atlanta
Distribution: RH9.0
Posts: 25

Original Poster
Rep: Reputation: 15
Tried all of this...still nothing....WOW...this linux box is really Fun! NOT!

Here are the configs taken from a Machine (win2kpro) that is on a static ip scheme, that surfs just fine on my network:

IP: 192.168.1.73
Subn: 255.255.255.0
Gate: 192.168.1.1
DNS: 207.155.183.72 and 207.155.183.73

That is it!!!!

I am running DNS inside my office for the DHCP clients to use...when a machine is on DHCP, the DNS reads 192.168.1.111 (server ip address)

This is getting very discouraging...i cant even get the simple things done in this software.

I have tried setting it up to be a DHCP client....and it is not pulling and ip info....does it matter that the DHCP server is a Windows 2k Server?

Is it normal to have the log in screen to say "Welcome to LocalHost"? When i go to log in...it says it could not lookup internet address for localhost.... What is all this?



AHHH!

Help!

Last edited by jwyant; 06-11-2003 at 10:25 AM.
 
Old 06-11-2003, 11:12 AM   #10
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 60
Post your /etc/hosts file and /etc/hostname file. Try checking the hosts file in Windows for the stuff you need.

If you don't have /etc/hostname, create it and put just one line in it, the name of the Linux box.

DHCP mini-HOWTO
 
Old 06-11-2003, 11:14 AM   #11
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 60
Another idea:

If you are running a firewall on the Linux box, disable it and see if you can connect. That may not be configured yet.
 
Old 06-11-2003, 12:15 PM   #12
MArgRes
Member
 
Registered: Jun 2003
Distribution: Fedora Core 2
Posts: 37

Rep: Reputation: 15
Don't give up!!!

Patience, young padawan.
Things are different in Linux when you're used to Windows machines. But, once you get the hang of it, you'll be addicted.

First, you HAVE to get to the command prompt. Click on the 'redhat' logo (where the start menu is in Windows) and go up until you get to 'System Tools', there should be a blue icon in there towards the bottom called 'Terminal'. That's the one you want. I don't know why they just didn't put it as an icon on the taskbar, but they didn't. Open up a couple of them.

Next, it sounds like you haven't set your hostname yet, since it is saying 'Welcome to Localhost'.

The easiest way to configure all of this stuff is by running 'redhat-config-network' (as root). (You can also get ther by clicking Redhat->System-Settings->Network). Click the DNS tab and enter the hostname of your machine, if you haven't already. If you haven't put in your DNS servers and the DNS search path, put those in there too. Next, click the 'Hosts' tab. You should have an entry that says '127.0.0.1 localhost.localdomain localhost'. DON'T REMOVE IT!!! That has to be there for good reasons. Go back to the 'Devices' tab and select the 'eth0' device and click on 'Edit'. I believe the settings to select DHCP are in there. Make sure that is selected. Once you've done all of that, 'Apply/OK' it all.

Now see if your computer is talking to the network at all. As root, type in 'ifconfig'. It will list all of your network adapter settings (including the loopback interface). Does eth0 have an ip address that would have been assigned from the DHCP server? If so, then things are good. Try pinging another computer ip on your network. If not, then something is messed up in your settings and we'll go from there.

You might want to check out Redhat's docs while you're doing this all as it walks you through it pretty well.

Let's start there. Let me know what things look like and I'll try to help you figure it out.
 
Old 06-11-2003, 01:23 PM   #13
jwyant
LQ Newbie
 
Registered: Jun 2003
Location: Atlanta
Distribution: RH9.0
Posts: 25

Original Poster
Rep: Reputation: 15
Marg,

Thank for all the tips. I went to verify the host tab under network configs, and there was no 127.xxxx entry...I might have messed with it last night....trying to learn!

Anyway, I decided to reload the system with the software...and on the walkthrough...i did see the Hostname box...I just used LINUX9.....and enabled DHCP in the startup.

its almost done...i will verify all the setting in a few...and reply back!

Thanks
 
Old 06-11-2003, 01:40 PM   #14
jwyant
LQ Newbie
 
Registered: Jun 2003
Location: Atlanta
Distribution: RH9.0
Posts: 25

Original Poster
Rep: Reputation: 15
Ok....reloaded and reconfigured the network......and....NO LUCK. BUT!

I can ping my windows machine.....and the nic card on the linux box (eth0) was assigned an ip address that is in the DHCP server. Now...when i open mozilla, after i type in http://www.ibm.com, is says (on the bottom of the screen) is starts saying "Resolving host www.ibm.com". It then displays and error that it can not find the host www.ibm.com

I guess i got a step further...but still....very frustrating!

HELP!!!


UPDATE!!!!

I have a feeling it is something to do with my DNS. I run Windows 2000k DNS on a server (192.168.1.111). I changed the first line of the DNS Entries on the network config screen, and the REsolving name @ the bottom of Mozilla went away...then it read connecting to IBM.com. Then it just times out.

The machine that i am on (typing these posts) is a Win2kPro machine....The host file has:

"127.0.0.1 localhost"

that is it.

all ip info are the exact same in the two boxes....but the linux does not surf. Here is the details in the /etc/host file:

"127.0.0.1 LINUX9 localhost.localdomain localhost"


Last edited by jwyant; 06-11-2003 at 02:03 PM.
 
Old 06-11-2003, 02:01 PM   #15
MArgRes
Member
 
Registered: Jun 2003
Distribution: Fedora Core 2
Posts: 37

Rep: Reputation: 15
Now it sounds like a DNS issue. Try pinging the actual ip of www.ibm.com 129.42.19.99. If you can ping it, then we know for sure. Did you fill out the DNS tab in the network dialog? Maybe post your /etc/resolve.conf file...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
newbie needing little help lordashraf Linux - Software 9 11-02-2005 09:56 AM
Newbie needing some help in Knoppmyth... davidbix Linux - Newbie 1 10-20-2005 07:40 PM
RH newbie needing help! X questions dirtrider82 Red Hat 0 01-14-2005 05:35 PM
newbie needing some help linu Linux - Hardware 7 09-01-2004 06:37 PM
Another Newbie Needing Help kimbo1962 Linux - Newbie 8 03-14-2004 09:15 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 02:48 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration