-   Linux - General (
-   -   Need help with Redhat 8 and nvidia drivers for geforce 4 (

ashleygorell 10-06-2002 09:01 AM

Need help with Redhat 8 and nvidia drivers for geforce 4
ok well i install the kernel and glx fine. no probs there, i edit the XF86config file load "glx" and driver "nvidia" , ok done.

reboot and all i get is a black screen everytime and it does the same when i use mandrake 9, gentoo 1.2 & 1.4 and debian.

it is really starting to piss me off cos i dont know what im doing wrong, i just dont understand.

can anyone honestly say that theyve got theres to work cos i dont know how.

Can someone please help me and tell me step by step what to do hopefully im missing something minor or is the problem geforce 4.

Well thanks in advance


Mara 10-06-2002 09:36 AM

Change your default runlevel to 3 (in /etc/inittab), reboot. Log in in text mode, run
Look for error message you get. The problem should be described.

ashleygorell 10-06-2002 10:24 AM

the problem changes sometimes its a cant load glx but most of the time it ses someting about the screen sync or something error 11 i think

Thymox 10-06-2002 11:43 AM

It would help enormously if you could post the exact error. Also, perhaps your XF86Config-4 files... or rather, the appropriate sections of them.

duaux 10-07-2002 01:11 AM

im running rh8 (trying it out)

and have a gf4

compiled from source, edited my XF86Config had problems

went backwards 1 step at a time.

1 step back... editign the XF86Config

i guess it would be the Monitor settings...

changed it manually since it didnt detect my Samsung SyncMaster 950p... got specs from manual

wala, all works.

PS. do what Mara said: change ur runlevel to 3 and then do all ur editing there

beyond_2000 10-07-2002 05:07 AM

comment the line Load "glx", then startx, you can see your desktop.
when you do this , you have no 3D accelerate in Linux.
nVidia driver for linux seems doesn't support 3D.

ashleygorell 10-07-2002 05:40 AM


how do i change the runtime level, init3 or something what file do i edit?

beyond_2000 10-07-2002 06:16 AM

just edit /etc/X11/XF86Config.

nerfherder64 10-07-2002 09:01 AM

3D acceleration does work. Look here for a lovely thread discussing installation of the nVidia drivers under Redhat 8.0 (and elsewhere in the same forum for other distros):

Amerist 10-07-2002 11:32 AM

I just recently installed the NVIDIA drivers under Redhat 8. I followed the PDF file to the letter, using the Tarballs and that worked swimmingly. I see a full-screen NVIDIA logo now whenever X loads, so I know that the driver install was a success. Plus, now my interface is a bit swifter.

nerfherder64 10-07-2002 11:47 AM

What I haven't been able to do is to get TwinView working. Details of my woes can be found here:

yvovandoorn 10-15-2002 05:11 PM

my issue is that i have a "non probed" monitor and when I try to load X it exits with the EE that there were no screens found.

These problems are fixed when switch back the vesa drivers... so not cool I tell you.

I do not have these issues on Mandrake 9 however, same setup, same monitor. So this is a Redhat 8.0 issue.

FairyNuf 10-24-2002 03:09 AM


I had the same error at one point.

I got x to work fine by fully configuring my monitor (tape measure, manufacturers quoted refresh rates, etc.) within the VESA driven X and then, having backed up XF86Config to another file did the "vesa" to "nvidia" edit and rebooted.

All was fine after that.

PooFace 03-15-2003 10:44 PM

Still, a pain
I guess this is what I get for trying to get away from MS... 1 hour into my Linux experience I want to put 2,000lbs of explosive into my PC.

So far, however, Windows seems to be a better solution. So why Linux:Pengy: Seems others have had this problem, and have gone through lots of hair-pulling to figure it out. Must've been a damn good reason to go through all that... I've gone through enough myself, and I wanna know why so many other people did.

I don't know how much more of this I can take, I don't know the syntax, I don't know the commands, I can barely find my way around this Gnome crap. If anyone could mail me instructions for doing it on an i686, translated into Idiot, that'd be remarkable. (I'm not really expecting anyone to...)

I've tried to do it myself ... lets see ... 26 2/3 times (in the process of #27) and if this keeps up my HD is going to smelt everything into one big black smelly lump of worthlessness.

rnturn 03-16-2003 12:12 AM


Originally posted by ashleygorell

how do i change the runtime level, init3 or something what file do i edit?

Look at the file `/etc/inittab'. You'll see (about 20 lines down) a line that looks like:


Change it to read:


and reboot. You'll be greeted by a plain ol' console login prompt. After you login, you'll need to start X with a `startx' command. When X fouls up, you can also check the log that XFree86 maintains in /var/log (XFree86.0.log).

BTW, before tweaking the inittab file, I'd recommend making a backup copy:

cp /etc/inittab /etc/inittab.20030315

or similar. Just in case.

Good luck,

All times are GMT -5. The time now is 12:16 AM.