-   Linux - General (
-   -   Need help with Enlightenment (

itsgregman 05-22-2013 02:18 PM

Need help with Enlightenment
Hi all,
I've recently upgraded to the new E17 on Pclinux and have a problem I couldn't seem to get any help with on their forum.
Since installing the new version all dialog boxes are greyed out, I can still check boxes and click buttons but if something needs to be manually entered it's like pulling teeth.
I suspect my user doesn't have the requires permissions but have no idea what groups I should add my user to. I even tried logging into a session as root and couldn't write to those fields.
Certain things like shortcuts I can simply create a .desktop file as a workaround but that doesn't work when trying to do things in the configuration panel.

frankbell 05-23-2013 08:36 PM

My first guess would be that something went wrong during the installation, especially if even root cannot access portions of the configuration dialogs.

I've been using Enlightenment for several months now on three machines (one Mint, two Slackware--Current) and encountered nothing of this sort. (I have come to quite like it.)

Can you be more precise about exactly what dialogs/configuration items are not responding, perhaps even post a couple of screenshots as examples?

Also, I've never used PCLinuxOS. Does it use repositories or did you install E17 in some other way?

itsgregman 05-24-2013 03:25 AM

1 Attachment(s)
Thank you for the response Frankbell.
I've been using Enlightenment myself since KDE4 came out, first on Elive for about a year and a half, then on Pclinux since then.

As for what kind of dialogs, pretty much all that have a field for manual entry. For a couple examples if I right click on an icon on the menu I will have icon Foo with a submenu containing properties and remove. If I click properties it brings up the desktop entry editor. in the editor all fields are greyed out but all buttons and check boxes are accessible.

Attachment 12595

Even this screenshot I took, as the fields were greyed out I couldn't even name it and just had to take the name the system had for it.

Also in the Settings panel, as an example if I wanted to create a new profile to save my settings, I am unable to because as the fields are greyed out I can't name the new profile.

This all started with the installation of the new updated E17. Initially I did and upgrade on 2 systems, both pclinux 1 from 2009 1 from 2010. both had this issue. I downloaded the newest iso and reinstalled both systems so both systems performance is improved but still have the greyed out dialogs. As this issue was on both updated older systems and newly installed I know this issue isn't from a bad install.

Pclinux uses repositories (apt-get + rpm). I really suspect whoever made the packages slipped up and set an option wrong, so I'm hoping someone who really knows Enlightenment can point me in the right direction on this issue.

frankbell 05-24-2013 08:30 PM

I'm sorry, I couldn't make out much in the screen shot, because of the color combination and the size of the dialog box.

It's a shot in the dark, but one thing that I have observed in occasional E17 dialogs (Enlightement 0.17.1 on Slackware--Current) is sometimes a dialog is unresponsive until I click something. For example, in the wallpaper dialog when I want to change a wallpaper, where there is the choice between "this desktop" and "all desktops," if "this desktop" is selected and the "Apply" button is not available, clicking "all desktops" brings the button back to life. Then the dialog comes alive and I can make and apply the choices I want.

Also, in the menu in the "Enlightenment" section, click "About" and let us know exactly what version you are using. The version that shows as "E17" in the Mint 13 repos is actually 0.16.9999.xxxx in the "About" dialog.

itsgregman 05-24-2013 11:35 PM

I'm using Enlightenment version 17.2.1

I am aware of what you are saying about buttons not becoming available until changes are made but this is a different issue.

What I have are pretty much all entry fields in Enlightenment being greyed out across the board.

Like I said before if I want to create a new profile the first step is to choose a name for it but as the fields where I would type the new profile name is unavailable I can't create one. Same with the screenshot I took, as I was saving it I am unable to name it as the field is greyed out, I can go back later and right click on the saved image and choose rename from the right click menu but that is only because I'm using Dolphin to do it instead of Enlightenment.

You said you couldn't see the image I posted, Did you click on it to get a larger view? If you look at the screen it should be obvious that the fields where I would normally be able to type are greyed out and inaccessible.

I'm surprised Mint is still using the older release of Enlightenment, of course that may be a good thing as I never had any issues like this with the version you're using.

frankbell 05-25-2013 07:32 PM

I have Enlightenment 0.17.1 on two boxes and have none of these issues.

I did view the screenshot in the larger view, but I still had difficulty reading the gray-on-black. Perhaps if you cropped it down so that the actual dialog box would be proportionally larger I would have more luck.

When you are talking about "Create a Profile," are you referring to Settings Panel-->Settings-->Profile or some other menu location? I'm asking because I want to test in the same areas you are talking about.

I snapped this screenshot using the Enlightenment screenshoot tool in the titlebar and was able to name and save it in the initial screenshot dialog.

I'm more and more concluding that is not a global Enlightenment problem, but something to do with your installation or the package you installed, but I'll be happy to test in any area of Enlightenment you wish.

itsgregman 05-26-2013 02:29 AM

When I referred to creating a profile I meant going to left click settings-settings panel-then settings tab-then profiles-then add, at this point it asks you to supply a name for the new profile which is not possible as the entry field is greyed out and not writable, so a new profile can not be created. This issues seem consistent in all configurations in Enlightenment across the board.

As for the screen shot what is written in the field is not relevant as I manually created a .desktop file in /home/user/.local/share/applications to correct what was in the field, but that isn't always possible in all situations. what is relevant about the screen shot is that the fields are greyed out and not modifiable as are all entry boxes in Enlightenment.

I do realize it is probably something done by the packager rather than something inherent in the new Enlightenment Having just installed Enlightenment 17.3 last night onto my Slackware install without any similar issue.

I wish there was some way to find an Enlightenment dev who could point me in the right direction on how to fix this issue or at least let me know if it was hopeless. Ive looked on Google extensively but have been unable to find anything recent or the same issue.

Thank you again for making the effort Frankbell.

itsgregman 05-26-2013 03:05 AM

I found the solution after another Google search.

It was an issue with the widget portion of the Enlightenment theme. Funny thing is I tried over a dozen themes and it never worked, but using the default themes widgets fixed the problem.

Many thanks to Frankbell for all the help.

frankbell 05-26-2013 09:15 PM

Cool beans. Glad you're working.

Hopefully the link you posted will help someone else down the road.

All times are GMT -5. The time now is 02:20 PM.