LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (https://www.linuxquestions.org/questions/linux-general-1/)
-   -   need compile help (https://www.linuxquestions.org/questions/linux-general-1/need-compile-help-38349/)

qanopus 12-14-2002 01:35 PM

need compile help
 
Hi, I need help with compiling scribus.
scribus needs qt. When I do "./configure" I get this error :

checking for Qt... configure: error: Qt (>= Qt 3.0.2) (library qt-mt) not found. Please check your installation!
For more details about this problem, look at the end of config.log.
Make sure that you have compiled Qt with thread support!

I don't understand this because by doing "ls -al /usr/lib/libqt" I get *:


ls -al /usr/lib/libqt*
lrwxrwxrwx 1 root root 17 Dec 1 01:35 /usr/lib/libqt-mt.so.3 -> libqt-mt.so.3.0.3
lrwxrwxrwx 1 root root 17 Dec 1 01:35 /usr/lib/libqt-mt.so.3.0 -> libqt-mt.so.3.0.3
-rw-r--r-- 1 root root 6107748 Mar 29 2002 /usr/lib/libqt-mt.so.3.0.3
-rw-r--r-- 1 root root 10201756 Mar 16 2002 /usr/lib/libqt.a
lrwxrwxrwx 1 root root 14 Dec 14 19:21 /usr/lib/libqt.so -> libqt.so.3.0.3
lrwxrwxrwx 1 root root 14 Dec 1 01:35 /usr/lib/libqt.so.3 -> libqt.so.3.0.3
lrwxrwxrwx 1 root root 14 Dec 1 01:35 /usr/lib/libqt.so.3.0 -> libqt.so.3.0.3
-rw-r--r-- 1 root root 6089220 Mar 29 2002 /usr/lib/libqt.so.3.0.3
lrwxrwxrwx 1 root root 20 Nov 27 18:59 /usr/lib/libqthreads.so.9 -> libqthreads.so.9.0.0
-rw-r--r-- 1 root root 3888 Mar 27 2002 /usr/lib/libqthreads.so.9.0.0
lrwxrwxrwx 1 root root 18 Dec 1 17:33 /usr/lib/libqtmcop.so.1 -> libqtmcop.so.1.0.0
-rw-r--r-- 1 root root 27460 Aug 21 17:54 /usr/lib/libqtmcop.so.1.0.0


As you see, all the libs are there.
I also notist that there is a directory "/usr/llib/qt3" To be on the save side, I made a symlink called include to my qt headers which were located in "usr/include/qt". I also make a directory "lib" were I made symliks to my qt libs.
I also make the right env. vars:

LD_LIBRARY_PATH=/usr/lib/qt3//lib
QTDIR=/usr/lib/

The end of my "config.log" file looks like :

configure:6824: checking for Qt
configure: 6888: /usr/lib//include/qstyle.h
configure: 6888: /usr/lib//qstyle.h
configure: 6888: /usr/lib/qt3/include/qstyle.h
taking that
tried NO
tried /usr/lib//lib
configure:7000: rm -rf SunWS_cache; c++ -o conftest -O2 -fno-exceptions -fno-check-new -I/usr/lib/qt3/in
clude -I/usr/X11R6/include -DQT_THREAD_SUPPORT -D_REENTRANT -L/usr/lib/ -L/usr/X11R6/lib conftest.C
-lqt-mt -lpng -lz -lm -ljpeg -ldl -lXext -lX11 -lSM -lICE -lresolv -lpthread 1>&5
In file included from conftest.C:2:
/usr/lib/qt3/include/qglobal.h:559: qconfig.h: No such file or directory
/usr/lib/qt3/include/qglobal.h:564: qmodules.h: No such file or directory
conftest.C:6: private/qucomextra_p.h: No such file or directory
configure: failed program was:
#include "confdefs.h"
#include <qglobal.h>
#include <qapplication.h>
#include <qcursor.h>
#include <qstylefactory.h>
#include <private/qucomextra_p.h>
#if ! (QT_VERSION >= 302)


Any sugestions ?

qanopus 12-14-2002 02:28 PM

Ok, I got it to work So don't bother.
Now to compile the damn thing. If that goes wrong, bother any way (please)

Bert 12-16-2002 09:23 PM

How did you get this to work?

gigsvoo 12-17-2002 04:36 AM

This is funny....

qanopus 12-17-2002 05:24 AM

I needed the qt-devel package. After installing that it worked.

gigsvoo 12-17-2002 05:27 AM

Oic... glad you made it.

Bert 12-17-2002 06:03 AM

Cheers! (compiling Scribus at the mo!)

Bert 12-17-2002 12:04 PM

It worked. Yipee!

qanopus 12-17-2002 02:55 PM

Oh, ok, so you installed it to. How do you like it? Pretty nice hu?

Bert 12-17-2002 03:27 PM

It certainly does a better job of PDF than anything I've seen yet for GNU/Linux. And I've seen them all.

gigsvoo 12-17-2002 08:55 PM

Does it works better than Adobe PDF Reader?

qanopus 12-18-2002 04:07 AM

Adobe PDF Reader, is a pdf viewer. We are talking about the stuff that makes the pdf. So you don't have much of a compairissen there.
But anyway, does it do a better job that adobe software?

gigsvoo 12-18-2002 04:20 AM

Cool.... where is it located?

Bert 12-18-2002 04:20 AM

The comparison between scribus and Acrobat is understandable but scribus has more functionality in places. Adobe Acrobat is really just a front end for the PDFWriter (which incidentally used to be free :mad: ) - I have never managed to get Acrobat Distiller to work properly so in that respect, embeddable fonts, hyperlinking and indexing make scribus better than Acrobat tools.
But Scribus Qt GUI looks and feels nicer than Acrobat in Windows too - and this is important.

Gosh, it's just not Adobe's week is it?

;-(

qanopus 12-18-2002 07:44 AM

"Gosh, it's just not Adobe's week is it?".
What do you mean?


All times are GMT -5. The time now is 01:15 AM.