-   Linux - General (
-   -   nam not working in n2.33 in ubuntu 10.04 (

manjunath11 11-03-2010 09:34 AM

nam not working in n2.33 in ubuntu 10.04
hi Sir,
I have installed Ns2.33 and added the patch mobiwan-1.patch. when i tried to run nam, the following is the error i got

manju@manju-desktop:~/Desktop/ns-allinone-2.33/ns-2.33$ nam
[code omitted because of length]
: no event type or button # or keysym
while executing
"bind Listbox <MouseWheel> {
%W yview scroll [expr {- (%D / 120) * 4}] units
invoked from within
"if {[tk windowingsystem] eq "classic" || [tk windowingsystem] eq "aqua"} {
bind Listbox <MouseWheel> {
%W yview scroll [expr {- (%D)}] units
bind Li..."

knudfl 11-03-2010 09:58 AM

Welcome to LQ.

cd ns-allinone-2.33/tk8.4.18/ &&
patch -p0 < tk-8.4-lastevent.patch


manjunath11 11-04-2010 01:00 AM

when i did , i got the following error
manju@manju-desktop:~/Desktop/ns-allinone-2.33/tk8.4.18$ patch -p0 < tk-8.4-lastevent.patch
patching file generic/tk.h
Reversed (or previously applied) patch detected! Assume -R? [n] r
Apply anyway? [n] n
Skipping patch.
1 out of 1 hunk ignored -- saving rejects to file generic/tk.h.rej

knudfl 11-04-2010 01:55 PM

None of the information, you show in post #3 is an error.
May be you by accident tried to apply the patch twice ?

Next step : Recompile tk and nam : By running ./install again.

Alternatively use a binary nam, 32bits : nam-1.14.i586.tar.gz

64bits :


abhishek majumder 05-02-2011 03:00 AM

thank you for providing me the procedure to run nam

All times are GMT -5. The time now is 05:24 AM.