LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 10-19-2010, 07:18 AM   #1
pbalaji2010
LQ Newbie
 
Registered: Oct 2010
Posts: 2

Rep: Reputation: 0
My minicom configuration settings are not updated.


Hi all,
Initially i wrongly entered the serial port device as ttys0 and save it. It wont reply due to wrong device selection.
Actual device is ttyS0 and i select this and try to save it as dfl,but an message appear as
'cannot write to /etc/minicom/minirc.dfl'
So i have to configure each and every time i open the minicom.Please tell me how to configure this correctly?


Thanks in advance.

kind regards

Balaji

Last edited by pbalaji2010; 10-19-2010 at 07:20 AM.
 
Old 10-19-2010, 12:39 PM   #2
Wim Sturkenboom
Senior Member
 
Registered: Jan 2005
Location: Roodepoort, South Africa
Distribution: Slackware 10.1/10.2/12, Ubuntu 12.04, Crunchbang Statler
Posts: 3,786

Rep: Reputation: 282Reputation: 282Reputation: 282
You probably need to be root to change the default minicom configuration.

If everything else fails, you can just find that file and edit it

Contents looks like
Code:
# Machine-generated file - use "minicom -s" to change parameters.
pu port             /dev/ptyp0
pu baudrate         9600
pu bits             8
pu parity           N
pu stopbits         1
Hope this helps.
 
1 members found this post helpful.
Old 10-20-2010, 01:01 AM   #3
pbalaji2010
LQ Newbie
 
Registered: Oct 2010
Posts: 2

Original Poster
Rep: Reputation: 0
Thanks Wim,

I change the settings as root & save and it is updated now. It is working properly.
Thank you very much.
 
Old 10-20-2010, 11:40 PM   #4
Wim Sturkenboom
Senior Member
 
Registered: Jan 2005
Location: Roodepoort, South Africa
Distribution: Slackware 10.1/10.2/12, Ubuntu 12.04, Crunchbang Statler
Posts: 3,786

Rep: Reputation: 282Reputation: 282Reputation: 282
Pleasure.

Please mark the thread as solved using the thread tools just above the first post.
 
Old 02-25-2011, 03:49 PM   #5
rpaladu2
LQ Newbie
 
Registered: Feb 2011
Posts: 1

Rep: Reputation: 0
thank you so much... did with sudo and it worked.

Thanks
Ravi
 
Old 06-26-2013, 09:51 PM   #6
karuanakar reddy
LQ Newbie
 
Registered: Jun 2013
Posts: 1

Rep: Reputation: Disabled
thanks

you should be in root to configure the minicom settings
 
Old 11-20-2013, 10:46 AM   #7
Sigg3.net
Member
 
Registered: Mar 2008
Location: Oslo, Norway
Distribution: Slackware 14.1 64-bit, Ubuntu 15.10, Fedora 17, Ubuntu 12 LTS and Ubuntu server 10.04
Posts: 173

Rep: Reputation: 28
Running
Code:
su -c 'minicom -s'
did the trick for me (Fedora 18). I had simply forgot that I ran it as root the first time:P
Thanks!


Tip: Read the man page for minicom. During a "call" you can hit CTRL+A to get up a "meta menu".
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
minicom configuration peji Linux - Software 2 04-18-2012 12:45 PM
Minicom Configuration For USB carlosinfl Linux - Hardware 1 04-29-2010 08:38 PM
Minicom configuration is missing 57600 baud rate David Pikary Linux - Software 7 09-26-2009 08:43 PM
Modem Configuration with minicom tayyab Linux - Hardware 1 09-01-2005 09:02 AM
Router Configuration & MiniCom ? Pravat Linux - Networking 1 04-24-2005 04:56 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 03:41 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration