LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (https://www.linuxquestions.org/questions/linux-general-1/)
-   -   Must type startx after login to get itno gui? (https://www.linuxquestions.org/questions/linux-general-1/must-type-startx-after-login-to-get-itno-gui-27409/)

HellBound 08-07-2002 10:00 AM

Must type startx after login to get itno gui?
 
I heard its suppose to just start up automaticly but it doesn't I have to type startx everytime I want to get in to the gui.
Any idea what the problem is?
Or is this normal?

jetblackz 08-07-2002 10:25 AM

Depending on your distro & login gui, normally, you make sure this is the case

/etc/inittab

id5:initdefault:

I suppose yours is id3.

HellBound 08-07-2002 11:20 AM

no I forgot to mention it also says its in N 5 when I check the level.

dorward 08-07-2002 01:05 PM

Check that you have an RPM for one of the following installed:

"kdm"
"gdm"
"xdm"

rooman 08-07-2002 03:37 PM

autostart your GUI
 
Hi there, you must have a control panel somewhere in RH which will have the option to automatically start the GUI on startup.

gbrad 09-05-2002 09:01 PM

Or, you can just add the following line:

startx

to a file that runs during init (such as the hidden .bash_profile in your home directory). Doing so will load your default GUI at login.

jetblackz 09-08-2002 11:22 AM

Or you missed the option that asked you during install if you wanted to start x at startup.

jrclare 10-04-2002 11:40 AM

warning--maybe misguided though.

don't put startx in your root .bash_profile--if you have a problem with X you might go into an endless error loop.

if you are a newbie don't put anything in the root hidden files.


All times are GMT -5. The time now is 05:18 AM.