-   Linux - General (
-   -   Mouse Wheel in Xorg (

Sugarat 09-01-2006 12:11 PM

Mouse Wheel in Xorg
Hi All,

Running Slackware 10.2 and Kernel 2.6

I have the mouse working in Xorg but the mouse wheel doesn't work.

In xorg.conf I am using ZAxisMapping 4 5 and protocol IMPS/2 as I normally do, but for some reason the wheel isn't working !?

lurko 09-01-2006 08:24 PM

so do you have

ZAxisMapping 4 5

Option "ZAxisMapping" "4 5"
in your xorg.conf?

the former is incorrect, the latter is not.

Sugarat 09-02-2006 06:03 AM

Yes, the latter..

The same code as I always use, except for some reason it's not working! :-(

Xorg.conf here

debiant 09-02-2006 06:57 AM

How about adding: Option "Emulate3Buttons" "true"

Sugarat 09-02-2006 08:58 AM

Added that to the mouse section, restarted X but still no joy :-(

debiant 09-02-2006 09:34 AM

do a xmodmap -pp and see what it returns. (You can almost assuredly remove the Emulate as well (left over from my Xree86 I believe

It's possible that the button mapping changed, then you would just change the xorg.conf to reflect that.

Sugarat 09-02-2006 09:37 AM


adam@gingernut:~$ xmodmap -pp
There are 5 pointer buttons defined.

    Physical        Button
    Button          Code
        1              1
        2              2
        3              3
        4              4
        5              5

Seems to match up?

Sugarat 09-02-2006 03:16 PM

Fixed... Not sure why, but I compiled the latest kernel with pretty much the very same config, and now it works... Weird.

2.6.17 works where the mouse wheel didn't in 2.6.13.


debiant 09-03-2006 04:00 PM

Did you report the bug or see if it had been reported?

All times are GMT -5. The time now is 02:57 AM.