LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (https://www.linuxquestions.org/questions/linux-general-1/)
-   -   Mouse change problem. (https://www.linuxquestions.org/questions/linux-general-1/mouse-change-problem-35986/)

yadavankur 11-20-2002 12:29 PM

Mouse change problem.
 
My Logitesch PS/2 mouse started to give problems so I had to detach it. I reatache my older mouse which was not a PS/2 mouse. I ran kudzu (I use Mandrake LiNUX) on the konsole to configure tha mouse. When Kudzu started it gave a message that I have changed my mouse and that I should choose a new one from the menu. I was not sure about my Mouse type or the Port so I thought I'll choose anything and if the mouse does not work I'll try a new combination. It did not work and Kudzu wont let me try more combinations. When I run Kudzu on console there is a few seconds wait after which I get back to konsole prompt there is no error message. I did find some hardware related files that contained entries about hardware and even the mouse but I dared not comit the mistake of changing it manually.

How do I reconfigure my mouse?

Another problem bugging me is Mouse simulation. At some time while using KDE I had changed the default Key Bindings which allows me to simulate the mouse BUT only the motion and not the click!

Are there any keys that allow me to simulate the mouse clicks?

For Eg: In windows :(please do not mind my using windows - I have to) the mouse clicks!! are simulated by the key pad '+','return','0' and '.'.

Thymox 11-20-2002 12:33 PM

The simplest way?
Turn off the computer.
Unplug your mouse.
Boot Linux
- Let Kudzu tell you that you don't have a mouse.
Turn off the computer.
Plug in your mouse again.
Boot Linux
- Let kudzu tell you that you now have a mouse...
and repeat until you get it right :D

Alternatively, tell us about your mouse... what kind of plug does it have? You've identified that it's not PS/2, but is it USB or the old serial mice?

yadavankur 11-20-2002 12:44 PM

Its a USB mouse (I thought ther are only 2 kinds).

Know please I already am stupid enough to try these combinations of mine. Theres got be a simpler way.

zLinuxz 11-20-2002 05:37 PM

did you try what Thymox say then??

If it didn't work, well this may be because your initial configuration of your system did not include USB support for your system, in which case you would either have to re-install your entire system or recompile your kernel.

What version of mandrake are you using?
If I'm not mistaking, on the latest kernels (2.4.17+) USB comes supported as default.

Anyway, tell us what's going on, :)


All times are GMT -5. The time now is 03:59 PM.