-   Linux - General (
-   -   Mouse and Keyboard stop working when X loads (

BrigitteT 04-10-2004 02:41 AM

Mouse and Keyboard stop working when X loads
Trying to do an install of Red Hat 9 on an Abit BE6 II motherboard. Installed it on another machine just fine, but the board died. Brought out the old board, updated the BIOS. When loading RH9 in text mode, keyboard works fine. But when X finally starts, the screen goes blank for a long time, then my mouse and keyboard stop completely - as if they are not even plugged in! Then X comes up and there is no mouse and keyboard functionalty at all.

When Linux boots, I see it is loading USB drivers (they say "OK"). I tried disabling USB. My mouse and KB are both PS/2. Linux doesn't even detect my mouse.

I am very new to this. I need to know if there is a way to fix this problem.

Any help please???????

AutOPSY 04-10-2004 12:16 PM

veiw the contents of /etc/X11/XF86Config file. (plain text)

there should be an InputDevice line that should point to /dev/psaux for the mouse.

actually just post your XF86Config file, and I may be able to tell you exactly what to change.

BrigitteT 04-10-2004 01:08 PM

OKay. I'll do this. I have to capture the contents in text mode on the downed machine, copy it to a file and then move it to the machine that I am using to talk to you. The machine that is down is obviously not on the web. I have just abandoned Microsoft stuff and am very new to Linux. So I do apologize for my ignorance. But I am about to get this done and posted here.

Thanks for your reply. Finally I have some hope!


BrigitteT 04-10-2004 04:33 PM

Okay. I finally figured out how to get the XF86Config file here. I hope you can help. Here it is:

# XFree86 4 configuration created by redhat-config-xfree86

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "DevInputMice" "AlwaysCore"

Section "Files"
# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.

# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.

RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"

Section "InputDevice"
# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"

# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"

# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "PS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"

Section "InputDevice"
# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "ViewSonic OptiQuest V773-2"
DisplaySize 320 240
HorizSync 30.0 - 70.0
VertRefresh 50.0 - 180.0
Option "dpms"

Section "Device"
Identifier "Videocard0"
Driver "savage"
VendorName "Videocard vendor"
BoardName "S3 Savage4"

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 16
SubSection "Display"
Depth 16
Modes "800x600" "640x480"

Section "DRI"
Group 0
Mode 0666

BrigitteT 04-10-2004 08:01 PM

Just in case no one is able to help me actually solve this problem, I wonder if maybe someone can help me try to solve it by answering a few questions.

On my other motherboard Redhat recognized the mouse and keyboard just fine. And there was no loooong pause before loading X. With this other board Redhat doesn't find the mouse at all. Is there are reason why it won't even find the mouse?????

I'm wondering if maybe I should just get another motherboard.

AutOPSY 04-11-2004 02:00 AM

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "DevInputMice" "AlwaysCore"

Change the line InputDevice "DevInputMice" "AlwaysCore"

to read #InputDevice "DevInputMice" "AlwaysCore"

and restart the comp. hopefully starting X.
If you would study the file for a moment youd notice that the identifier lines:
DevInputMice --> (/dev/input/mice)
Mouse0 ---> (/dev/psaux)

are two different mouse devices.

and the USB mouse is set to. AlwaysCore no less.
That is exactly why your mouse doesnt work.

if it still fails, keep the existing changes but also make the Mouse0 the Always Core. instaed of Core Pointer .. make one change at a time. and retry.

Mouse0 is the ps/2 mouse hub.
DevInputMice is the USB mouse .
Also make sure the ps/2 equipment is enabled from the BIOS.
I can be of further assistance if you need.

BrigitteT 04-12-2004 12:10 AM

Well, I tried everything you said and then some. It had no effect.

I think this may be a bit more fundamental than a bad X configuration. I say this because even when I try to install Linux from scratch, all goes well until it tries to detect my mouse. I get "No Mouse" when in fact the mouse is certainly installed and the ports enabled. As long as I am in text mode, the keyboard works fine. But when the graphical interface tries to load, the video flashes, turns black and sits for a long time, then I get the graphical login screen and both mouse and keyboard are dead. The only thing I can do at that point is just reset the machine.

If you have any other ideas, I am all ears. Otherwise, thanks so much for your help.


vinay_s_s 04-12-2004 01:21 AM

well u can try this:
do all stuff as root and not user.

move the /etc/X11/XF86Config file to some other directory as a backup.

go to runlevel 3 by running
init 3

and then run:
if that command doesn't exist, then try

ps: sorry i dont remember the commands of redhat exactly since i have stopped using it.

All times are GMT -5. The time now is 11:18 PM.