-   Linux - General (
-   -   mounting digital camera? (

mbbender 07-08-2003 12:33 PM

mounting digital camera?
I'm using red hat 9 and a kodak dx3600

I am new to linux and having troubles figuring out how to get pictures off my camera. I've tried getting jPhoto but I don't have the required libraries and I really don't careif I have a GUI. I just want to be able to dump the pictures to my hd. I know you have to mount it, but I really don't know how to do that. Its a usb connection.

I have made a directory /mnt/camera

thats it! anyone know what I should do from here?

cav 07-08-2003 01:06 PM

Well heres what I did:

If its has a usb interface, which I assume it does, open a console and type:

tail -f /var/log/messages

then plug in and turn on your camera. The terminal should then shoot out some new lines that show where this new camera device is connected. Something should come up like /dev/sda1 or something.

Then all you have to do is mount /dev/sda1 /mnt/camera like you would mount any other hard drive. To make this easier to do in the future you could add an extra line in your /etc/fstab.

mbbender 07-08-2003 01:27 PM

thanks that worked, but I also found gtkam that came with red hat 9, I should have looked for that first I guess. thanks again

kaine 07-19-2003 01:49 AM

I'm having problems too...

... but when I type that command I only get

Jul 19 07:48:46 localhost kernel: hdd: packet command error: status=0x51 { DriveReady SeekComplete Error }
Jul 19 07:48:46 localhost kernel: hdd: packet command error: error=0xa0

scrolling down the terminal forever and ever.


Tenover 08-19-2003 12:08 AM

I have the same problem and followed the above advice....Here's what I got after plugging in the camera....Couldn't mount /mnt/camera either, I got the "Not valid block device" still....any ideas?

Aug 18 22:04:46 66-74-230-47 kernel: hub.c: new USB device 00:1d.0-1, assigned a
ddress 3
Aug 18 22:04:46 66-74-230-47 kernel: usb.c: USB device 3 (vend/prod 0x4a9/0x3070
) is not claimed by any active driver.
Aug 18 22:04:49 66-74-230-47 /etc/hotplug/usb.agent: ... no modules for USB prod
uct 4a9/3070/1
Aug 18 22:05:12 66-74-230-47 su(pam_unix)[4205]: session opened for user root by

All times are GMT -5. The time now is 09:53 PM.