LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 11-24-2001, 07:45 PM   #1
M.I.
LQ Newbie
 
Registered: Jun 2001
Location: United States
Distribution: Red Hat 7.2
Posts: 18

Rep: Reputation: 0
Mounting a vfat filesystem in RH 7.2


I just loaded up Redhat 7.2 for the first time, and I don't know how to mount my vfat partitions because I am used to using linuxconf with earlier versions of Redhat.

Thanks in advance.
 
Old 11-24-2001, 08:30 PM   #2
Dayewalker
LQ Newbie
 
Registered: Nov 2001
Location: Texas
Distribution: Redhat 7.2
Posts: 23

Rep: Reputation: 15
First, as root type in mkdir /mnt/vfat and then once that's done, use fdisk to figure out which partition is your vfat partition (unless you already know this info) and then type mount -t vfat /dev/hd? /mnt/vfat (where hd? is the actual partition you want to mount), and then once you've got the parition mounted, edit your etc/fstab and add the the following line: /dev/hd? /mnt/vfat vfat noauto,owner,users 0 0

Just line that info up with the other entries in the etc/fstab, exit and save the changes and you should be good to go. If I screwed this up at all please forgive me cause I'm still a newbie myself but I've dealt quite a bit with getting the vfat partitions mounted and useable for my system.
 
Old 11-25-2001, 05:54 AM   #3
webtoe
Member
 
Registered: Apr 2001
Location: Cambridge, England
Distribution: Slackware 10, Fedora Core 3, Mac OS X
Posts: 617

Rep: Reputation: 30
Dayewalker is correct excpet with the fstab file you may want instead of noauto to have auto so it reads like this

Code:
/dev/hd? /mnt/vfat vfat auto,users,rw 0 0
That's what mine looks like

Alex

Last edited by webtoe; 11-25-2001 at 05:55 AM.
 
Old 11-25-2001, 12:55 PM   #4
Dayewalker
LQ Newbie
 
Registered: Nov 2001
Location: Texas
Distribution: Redhat 7.2
Posts: 23

Rep: Reputation: 15
I've actually been wondering about what the difference between having auto and noauto there would make. The only guess I could come up with would be that with auto, it automatically mounted the partitions when the system was booted up instead of having to manually mount them via the KDE desktop or whatever other means desired. Am I correct in that? Also, what does the rw in your entry mean?

Last edited by Dayewalker; 11-25-2001 at 12:56 PM.
 
Old 11-26-2001, 09:59 AM   #5
webtoe
Member
 
Registered: Apr 2001
Location: Cambridge, England
Distribution: Slackware 10, Fedora Core 3, Mac OS X
Posts: 617

Rep: Reputation: 30
the auto does mean that it is mounted automatically when linux is started up. rw just tells it to mount it read-write rather than ro (read-only - used on cdroms and NTFS drives like windows 2000/XP)

Alex
 
Old 11-26-2001, 01:07 PM   #6
Dayewalker
LQ Newbie
 
Registered: Nov 2001
Location: Texas
Distribution: Redhat 7.2
Posts: 23

Rep: Reputation: 15
Ahh ok thanks
 
Old 11-26-2001, 03:29 PM   #7
M.I.
LQ Newbie
 
Registered: Jun 2001
Location: United States
Distribution: Red Hat 7.2
Posts: 18

Original Poster
Rep: Reputation: 0
I put the entry into /etc/fstab with the rw bit, and I can access the files O.K.

Then, to let myself write to it without logging in as root I ran 'chmod 777 /mnt/vfatd' however, I can't write to /mnt/vfatd without being root. Is there anything I'm missing?
 
Old 11-27-2001, 01:06 PM   #8
webtoe
Member
 
Registered: Apr 2001
Location: Cambridge, England
Distribution: Slackware 10, Fedora Core 3, Mac OS X
Posts: 617

Rep: Reputation: 30
i actually have the same problem. but for me it isn;t that annoying since i don't need to move things to the windows partition very often.

Alex
 
Old 11-28-2001, 09:06 PM   #9
pjrestrepo
LQ Newbie
 
Registered: Nov 2001
Location: Boulder, Colorado
Distribution: Red Hat
Posts: 10

Rep: Reputation: 0
To allow yourself (as opposed to "root") to read and write to a vfat file, this is how the line should look like in the fstab file:

/dev/hda2 /dosc vfat uid=500,gid=500,auto,rw 0 0

where uid=500 and gid=500 are your user ID number and group ID number, respectively. To find out what your uid and gid are, type "id" at the prompt.

Regards,

Pedro
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
write permissions in /etc/fstab for vfat filesystem btb Linux - Newbie 5 10-24-2005 01:37 PM
Can't boot XP, can only mount ntfs filesystem as vfat bsm80 Linux - Hardware 4 05-06-2005 05:56 PM
Filesystem other than vfat on pc card? JohnKFT Slackware 1 04-03-2005 12:54 PM
New 2.6 mount options make VFAT filesystem mounting saner TheOneKEA LinuxQuestions.org Member Success Stories 0 11-19-2003 12:05 PM
Can't mount Vfat or Msdos Filesystem!! RKris Linux - Software 6 06-19-2002 04:58 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 05:02 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration