LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (https://www.linuxquestions.org/questions/linux-general-1/)
-   -   Mount Problem for NTFS (WIN2k) FIle System (https://www.linuxquestions.org/questions/linux-general-1/mount-problem-for-ntfs-win2k-file-system-10736/)

atul_jadhav 12-28-2001 02:52 AM

Mount Problem for NTFS (WIN2k) FIle System
 
Hello there ,
I was trying to mount a win2k ntfs partition on linux 7.1
i used command
"mount -t ntfs /dev/hdc2 /mnt/hdc2"
but then system gave me message that
"kernal doesn't support ntfs file system"

is there any other way to mount win2k ntfs partition or what should i do to mount ntfs partition on linux 7.1

If you know the solution please email me at atul_jadhav@rediffmail.com

Thanks You Very Much
Best Regards

Atul

DavidPhillips 12-28-2001 05:50 AM

This is not a problem, it is going to require kernel support or module support for the file system. Most distros do not install with support for ntfs by default. As a matter of fact I don't know of any that do.

You should recompile your kernel and add support if you need it.

elist 12-28-2001 06:27 AM

Don't know. When I installed ML8.1 I was able to mount the NTFS partition while I was doing all the others, it ended up being on
/mnt/windows
I also had a FAT32, and the XP hidden partition so there was also
/mnt/win_c
/mnt/win_d

bobirt 12-30-2001 05:25 PM

Mount ntfs
 
I had the same message in MDK 8.0 but follow the steps:


0) in /mnt : mkdir (your hdXX or how you want to call it but keep it the same after)

1) In root: cat /proc/filesystems
-> it will give you the supported filesystems by your kernel
-> if ntfs is there then you must be able to mount it

2) /etc : vi fstab
-> add the line (in my case it is after cdrom)
-> dev/hdXX /mnt/hdXX ntfs defaults 0 0

save the file and exit.

reboot your system and hopefully it should work.

If you are using MDK 8.0 go to root:diskdrake
-> choose partitions to mount; then choose Toggle to expert mode, it will give you the options to whwre do you want to mount it. From there it is easy.

Hope it works.

infinity6 12-30-2001 09:53 PM

I don't know about Mandrake, but as of kernel 2-4, NTFS support was still experimental. Before you start playing around with NTFS partitions, realize that the kernel support may still be experimental!!! This could cause irreperable damage to files, file-system, or even the hard disk. If you want the whole details, I would check out http://www.kernel.org and see what the kernel developers have done lately before playing with it.

finegan 12-31-2001 09:50 AM

A lot of this depends on distrobution. NTFS support, at least read-only, has been in the kernel since mid-2.2.x, but most of the major distros didn't put it in as a module in their default shipping kernel until a major version later. I think for RH it first appeared as a default module in 6.2, Slackware I know it was in 7.0, the rest I'm fuzy on, but its part of the default in all of them now. Also, depending on distro, daemons like mountd may or may not be allowed to call for the loading of modules. Probably all you need to do is: insmod ntfs, and then go ahead and mount the drive as normal (just like you had it). There's a lot of scuttlebutt as to how un-stable leaving that module in the running kernel actually makes things. Basically, read-only; no problem in 2.4.x but kinda iffy in 2.2.x. Since 2.4.3 (I think), there has been write support, but using that is just a bad idea unless you want to hose your NTFS partition.

Read-write support for NTFS is probably going to kick off in a big way now that everyone and their dog has a dual boot win2k/XP+Linux box.

Cheers,

Finegan


All times are GMT -5. The time now is 11:49 AM.