-   Linux - General (
-   -   Mount image of NTFS generated by ddrescue (

krofna 01-18-2013 10:15 AM

Mount image of NTFS generated by ddrescue
I ran ddrescue on a failing external hdd (NTFS formated). It generated .img file, but I don't know how to mount it. Also, image is not complete. Since it took 17 hours to get 30 out of ~780 GB, I wanted to see whats rescued before I resume (Any tips on making it go faster?)


root@krofna-desktop:/home/krofna# mount -t ntfs hdd.img /mnt
Failed to read last sector (1953520001): Invalid argument
HINTS: Either the volume is a RAID/LDM but it wasn't setup yet,
or it was not setup correctly (e.g. by not using mdadm --build ...),
or a wrong device is tried to be mounted,
or the partition table is corrupt (partition is smaller than NTFS),
or the NTFS boot sector is corrupt (NTFS size is not valid).
Failed to mount '/dev/loop0': Invalid argument
The device '/dev/loop0' doesn't seem to have a valid NTFS.
Maybe the wrong device is used? Or the whole disk instead of a
partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?
How can I mount it?

jefro 01-18-2013 06:39 PM

Try this maybe kpartx -v -a rawimage.dd From here

Can't say what the state of the image is really either. It could be all hosed up.

Guess you could try qemu image.img to see if it even wants to boot long enough to tell you the hcl is wrong.

All times are GMT -5. The time now is 03:04 PM.