LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 04-05-2001, 03:28 AM   #1
jolly
Member
 
Registered: Mar 2001
Posts: 63

Rep: Reputation: 15
Angry


My hard disk has three partition c: fat 32 d: fat 32 and one non dos in which linux is installed
I want to access the data of C: which is in fat 32 how can I mount my c: to access the data
 
Old 04-05-2001, 05:44 AM   #2
ugge
Senior Member
 
Registered: Dec 2000
Location: Gothenburg, SWEDEN
Distribution: OpenSUSE 10.3
Posts: 1,028

Rep: Reputation: 45
first you make a mounting point in your fillesystem,
mkdir /mnt/winc
then run the command
mount -t vfat /dev/hda1 /mnt/winc
this assumes that your c: is the first partition on your primary master drive.

To make your c: available on boot then add the following to your /etc/fstab file:

/dev/hda1 /mnt/winc vfat defaults,auto 0 0
 
Old 04-05-2001, 06:21 AM   #3
drjimstuckinwin
Member
 
Registered: Mar 2001
Location: Manchester UK
Distribution: Mainly Fedora
Posts: 496

Rep: Reputation: 30
Hi
Trying to do this to mount my hdb which is my original Win98 disc. I get the message wrong fs type,bad option, bad superblock on /dev/hdb, or too many mounted filesystems.
Any ideas?
Regards
Jim
 
Old 04-05-2001, 08:28 AM   #4
mathi
Member
 
Registered: Nov 2000
Distribution: Slackware
Posts: 74

Rep: Reputation: 15
drjimstuckinwin, I think you're trying to mount the MBR, that is /dev/hdb. And you should try to mount the first partition, called /dev/hdb1.
 
Old 04-05-2001, 09:21 AM   #5
drjimstuckinwin
Member
 
Registered: Mar 2001
Location: Manchester UK
Distribution: Mainly Fedora
Posts: 496

Rep: Reputation: 30
AHA!
 
Old 04-16-2001, 05:21 AM   #6
mikkol
LQ Newbie
 
Registered: Apr 2001
Location: Vancouver, Canada
Posts: 4

Rep: Reputation: 0
Question

I wonder how to set the drive to be readonly in the fstab?
 
Old 04-16-2001, 08:01 AM   #7
webtoe
Member
 
Registered: Apr 2001
Location: Cambridge, England
Distribution: Slackware 10, Fedora Core 3, Mac OS X
Posts: 617

Rep: Reputation: 30
you put ro where all the options are in fsatb (the bit with defaults,auto)

so the endd looks like
default,auto,ro

simple

Alex
 
Old 03-24-2006, 10:36 PM   #8
ariestruong
LQ Newbie
 
Registered: Mar 2006
Posts: 18

Rep: Reputation: 0
I do as you guide, I use Fedora 5
"
mkdir /mnt/winc
then run the command
mount -t vfat /dev/hda1 /mnt/winc
this assumes that your c: is the first partition on your primary master drive.

To make your c: available on boot then add the following to your /etc/fstab file:

/dev/hda1 /mnt/winc vfat defaults,auto 0 0
"

But I when log in with "User" I can't anything except read files. I want I can read, write, copy, move, raname... but I can't. When I log in with "root" I can do everythings. Who know reason why? Pleasehelp me.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Where to mount temporary hard disk frazelle09 Linux - Hardware 2 09-03-2005 05:55 PM
Trying to mount a second hard disk clucas Linux - Newbie 8 11-11-2004 09:53 PM
How do I get my USB 2.0 Hard Disk to MOUNT? Hawky Linux - Newbie 5 10-26-2004 01:11 AM
How to mount my usb hard disk? raoqn Fedora 1 04-01-2004 06:21 AM
How to mount a New Hard Disk ! ? bennethos Linux - Newbie 6 10-16-2003 05:09 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 04:02 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration