LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 03-22-2003, 05:17 AM   #1
Stefangeelen
LQ Newbie
 
Registered: Sep 2002
Distribution: Suse 8.0
Posts: 5

Rep: Reputation: 0
Angry mount cdrom (SuSE 8.0 - VMWare 4 Beta)


Hi,

i just tried to install SuSE 8.0 under VMWare 4 Beta.

It seems to be impossible to install the VMWare tools:

At following command:

mount -t iso9660 /dev/cdrom /mnt

it gives following error:

wrong fs type, bad option, bad superblock on /dev/cdrom or too many mounted file systems (could this be the IDE device where you in fact use ide-scsci so that sr0 or sda or so is needed) ?

The fstab in /etc contains following (partially reproduced):

...
/dev/cdrom /media/cdrom iso9660 ro,noauto,user,sync 0 0
..

I think this is a 'newbie' problem so I post this here.

Any ideas...
 
Old 03-22-2003, 10:36 AM   #2
wr3ck3d
Member
 
Registered: Dec 2002
Location: IL
Distribution: NetBSD, Slackware, Gentoo, Debian, FreeBSD
Posts: 444

Rep: Reputation: 31
Not sure if this will help you but just for the heck of it i installed slackware in XP using vmware (3.2 i think???) a few months ago. This is from memory so could be wrong.

I went to the menu and choose "install VMware tools" then did a 'mount /mnt/cdrom'
I never use the -t flag or the device (that is what /etc/fstab is for).

Your fstab is showing....

/dev/cdrom /media/cdrom iso9660 ro,noauto,user,sync 0 0

The mount point for /dev/cdrom is /media/cdrom so try doing
#mount /media/cdrom to mount it. Post back if that doesn't work.

Then you have to copy the file in /media/cdrom to /tmp or whatever, untar it, then look at the instructions and see how it is installed for your distro. If Suse has a init folder i think it should be easy, Slackware doesn't so i had to copy the lines of text from the init files to the proper files.

Good Luck.

Last edited by wr3ck3d; 03-22-2003 at 10:42 AM.
 
Old 03-23-2003, 02:27 AM   #3
Stefangeelen
LQ Newbie
 
Registered: Sep 2002
Distribution: Suse 8.0
Posts: 5

Original Poster
Rep: Reputation: 0
Dear,

already many thanks for your feedback.

Unfortunately #mount /media/cdrom does not work (it gives the same error).

#mount /media/cdrom /mnt gives the error: /media/cdrom is not a block device.

Any other suggestions ?
 
Old 03-23-2003, 04:55 AM   #4
orange400
Member
 
Registered: Mar 2003
Location: Bellevue, WA
Distribution: Arch w/ XFCE
Posts: 834

Rep: Reputation: 30
Here's my fstab entry ...

/dev/cdrom /mnt/cdrom iso9660 noauto,owner,kudzu,ro 0 0

Give it a shot, it might work.
 
Old 03-23-2003, 05:25 AM   #5
Stefangeelen
LQ Newbie
 
Registered: Sep 2002
Distribution: Suse 8.0
Posts: 5

Original Poster
Rep: Reputation: 0
Oranga400,

thx for your answer.

I changed the fstab accordingly and have following result:

#mount /mnt/cdrom

results in

mount: mount point /mnt/cdrom does not exist

Any other idea ?
 
Old 03-23-2003, 11:14 AM   #6
wr3ck3d
Member
 
Registered: Dec 2002
Location: IL
Distribution: NetBSD, Slackware, Gentoo, Debian, FreeBSD
Posts: 444

Rep: Reputation: 31
Did you make sure that you first selected to "install vmware tools"???? What Vmware does is it makes a temporary virtual cd-rom that gets mounted and has the file in it. So you have make sure that you first select to create the virtual cd-rom by selecting vmware tools.

You are getting the mount point doesn't existing because you don't have a /mnt/cdrom folder.

This is how mounting works.......

#mount device location

So when you tried to do this
#mount /media/cdrom /mnt gives the error: /media/cdrom is not a block device.

You told it to mount /media/cdrom to the folder /mnt. /media/cdrom is not a device right??? it is a folder. That is why you got that error. It said "hey dude, what are you doing? /media/cdrom is not a device!!!"

You can mount a cd anywhere, you can make a foldeer called timbuktoo and use that to mount your cd's. Now the fstab just is a file so you dont have to always type the device and the folder and the file type everytime, you just type the folder and it already knows the rest just from looking into the fstab. Here is a fstab entry.....

/dev/cdrom /mnt/cdrom iso9660 noauto,owner,kudzu,ro 0 0

This is saying that when you type

#mount /mnt/cdrom

The mount point is /mnt/cdrom and that the actual device is /dev/cdrom and it is a iso9660 file system and it is read only. Also /dev/cdrom is just a symlink pointing to your actual cdrom device whether it is /dev/hdc or /dev/hdd or /dev/sd0, etc.

I also remember that Vmware changes some of the IDE devices to SCSI just so they can work, go into your Vmware setup file and see what you cdrom is set to....can you mount a regular cd?? Try that, if you can it will be the same command only with the Vmware tools install checked first.

Try this....(first selct to install vmware tools)
$su
#mkdir /mnt/cdrom
#mount /dev/hdc /mnt/cdrom if that doesn't work go to next
#mount /dev/hdd /mnt/cdrom " "
#mount /dev/sd0 /mnt/cdrom ""
#mount /dev/sd1 /mnt/cdrom

If none of those work, place a cd in your cdrom and try again, if you can't moujt a reguar CD, you have to find where is your cd-rom located.

Last edited by wr3ck3d; 03-23-2003 at 11:16 AM.
 
Old 07-17-2008, 12:04 PM   #7
sheenman_79
LQ Newbie
 
Registered: Jul 2008
Posts: 1

Rep: Reputation: 0
Cool mouting your cdrom

hi,
I had a simillar issue, where the linux guest OS just wouldn't load the /mnt/cdrom... which as correctly pointed out earlier by wr3ck3d (thank you we3cd3d!)

What I have done is give the command #dmesg |more
and you'll get a list out of all the mounts, and system settings... browse through this, and find the line where the CD/DVD ROM line shows up... the first few letters, tell you what the partition mount point is... (in my case - hdc)

after you have identified this,
1. create the folder cdrom in /mnt so you can browse to /mnt/cdrom
2. in the /etc/fstab file, enter the line
/dev/hdcur mount point /mnt/cdromfolder you created udf,iso9660 noauto,owner,kudzu,ro 0 0

hope this helps! good luck!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
CDROM refuses to mount, /dev/cdrom does not exist shane25119 Linux - Hardware 10 08-02-2009 11:43 PM
Suse 10 Beta 4 -- EVERYTHING WORKS 1kyle SUSE / openSUSE 3 09-11-2005 08:52 PM
VMWare 5 beta in production environment? jiml8 Linux - Software 3 02-26-2005 03:29 PM
Run all windows software VMware 5 beta free AwesomeMachine Linux - Software 4 02-02-2005 11:45 PM
VMWare question - device /mnt/cdrom is confused e-regular Linux - Software 4 09-15-2003 09:34 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 03:07 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration