-   Linux - General (
-   -   modprobe and insmod not working (

navin_karnam 07-30-2007 06:56 AM

modprobe and insmod not working

I was using Redhat EL 2.4.6 kernel without any problems for 1 year...

Now my problem is, its unable to run commands modprobe and insmod, because of this its unable

1) Detect ethernet card
2) unable to mount any devices(it is saying unknown fs ).

When i try to execute modprobe or insmod it saying :

/sbin/insmod: /lib/tls/ : Version `GLIBC_2.3.4` not found (required by /sbin/insmod)

Please any of u help me to get out of this problem...


Paul7 07-30-2007 10:50 AM

What you have changed?
You made a system update?
Then you have to check depends

dwhitney67 07-30-2007 10:50 AM

Seems like the problem is staring right at you... the Version "GLIBC_2.3.4" not found.

Have you tweaked the library paths on your system recently? Check if the libc-2.3.4 is still on your system. Normally it is placed in /lib.

If it is there, then as root, run the following command:


# /sbin/ldconfig -v |grep libc-
Post another message if you still have the same problem.

Matir 07-30-2007 11:36 AM

Also, try making sure you have the most current module-init-tools installed on this system.

navin_karnam 07-30-2007 11:58 PM


Thank you all for the replies...

I entered into /lib and i executed the command

/sbin/ldconfing -v | grep libc-

so its made to pint libc-2.3.2 and i did the same in /lib/tls/ directory also..

Still modprobe and insmod trying to find the GLIBC-2.3.4 ...
And in system i have not found libc-2.3.4 ..

what is the way to solve this ???

Thanks and Regards,

navin_karnam 07-31-2007 12:13 AM


One more problem i noticed by executing the command :

ldd /sbin/insmod

it is saying :

not a dymanic executable

But if i run the same command in othr machine

it is saying :
[naveen@LocalHost ~]$ ldd /sbin/insmod => /lib/tls/ (0x006f4000)
/lib/ (0x006d7000)


dwhitney67 07-31-2007 12:20 AM

From the output you provided it appears quite apparent that you have glibc-2.3.2 installed. The modprobe and insmod are looking for glibc-2.3.4 because that is what they were compiled against.

Have you updated your system recently? It's quite possible that you may have inadvertently copied these binaries for modprobe and insmod (and likely lsmod, etc) from a source that is not appropriate for your system.

What Linux distro are you using? Maybe if you did an update you might be able to set everything to normal. --- I just noticed you stated in the OP that you are using RHEL. Try running the following commands (as root):

# up2date up2date
# up2date

As a last resort, you should be able to find the original modprobe/insmod/lsmod/etc on your original CD for your distro.

Paul7 07-31-2007 06:13 AM

Hello naveen,
your libc,so.6 is link to an older version of libc which is libc-2.3.2. you need a higher version.
at my system I see
You can check the net for a higher version.
And tell us please what you have done before.

navin_karnam 08-01-2007 12:37 AM


I tried "up2date" but its unable detect the my linux installation cds.

Now insmod,modprobe and lsmod are working :

I copied the working insmod and lsmod form windows using LTOOL. But my problem still not solved.

whenever i try to mount usb stick it is saying :

mount: fs type vfat is not supported ...

and I am unable to browse ...


All times are GMT -5. The time now is 10:13 AM.