LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (https://www.linuxquestions.org/questions/linux-general-1/)
-   -   Midi not working, possibly output device problem (https://www.linuxquestions.org/questions/linux-general-1/midi-not-working-possibly-output-device-problem-119573/)

Druaga 11-24-2003 05:12 PM

Midi not working, possibly output device problem
 
The midi on my Slackware 9.1 machine is not working. The sound works fine for xmms and such. I dont use artsd or any sound server.

I open kmidi to play a midi file and it says output device error, i checked the error and it needs artsd to play. I turned on artsd and the sound quality is horrible (As i have always found with artsd). So i dont like that oen bit.

I tried Kmid and it gave me an error saying it couldnt open the sequencer. I checked the error and it was actually that it couldnt open /dev/snd/seq so i changed the permissions on that, and now when i run kmid it crashes.

Timidity just wont run, and i havent found out why yet. There is no error on the command-line or anything.

I downloaded a simple midi player called "midi". It says that /dev/sequencer doesnt exist. Which an "ls -l" shows me: "rw-rw-rw- 1 root sys 14, 1 Aug 29 03:47 /dev/sequencer" which should mean it exists and can output sound.

So any ideas to solve this problem?

Druaga 11-25-2003 03:52 PM

the errors in syslog i get from timidity is:
Code:

Nov 25 15:51:26 xen modprobe: modprobe: Can't locate module snd-card-1
Nov 25 15:51:26 xen modprobe: modprobe: Can't locate module snd-card-2
Nov 25 15:51:26 xen modprobe: modprobe: Can't locate module snd-card-3
Nov 25 15:51:26 xen modprobe: modprobe: Can't locate module snd-card-4
Nov 25 15:51:26 xen modprobe: modprobe: Can't locate module snd-card-5
Nov 25 15:51:26 xen modprobe: modprobe: Can't locate module snd-card-6
Nov 25 15:51:26 xen modprobe: modprobe: Can't locate module snd-card-7



All times are GMT -5. The time now is 07:35 PM.