LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (https://www.linuxquestions.org/questions/linux-general-1/)
-   -   Messed up partition table. (https://www.linuxquestions.org/questions/linux-general-1/messed-up-partition-table-387493/)

randrake 11-29-2005 02:10 AM

Messed up partition table.
 
I dual boot with xp, and Suse 9.3. I have 2 hard drives each with 4 or more partitions, suse is on a partition on hdb. I also have another partition on hda i like to use to try out dif. distributions. last night i installed knoppix 4 to this partition and after reformatting the partition and trying to install with the knoppix installer it would only give my suse partition as a choice of where to install to, so I decided to delete the hda partition and reformat again and this time it showed on the instalation option so I installed knoppix to hda2, however for some reason my Suse partition on the other hard drive was renamed and of course my Suse root directory is unhappy about it, i can boot into suse in text mode only, though I can cd to my home folder X will not start. I booted into my install dvd again and sought the option to restore my partition table but it stated deleting 3 partitions was necesary (not an option for me). Any one an idea on how to restore my partition table for this drive in an nondestructive maner? I can reinstall as data is backed up but would prefere to avoide it if possible. Tks in advance. :cool: Knoppix worked for awhile but kernel panic is all there is now.

Agrouf 11-29-2005 12:38 PM

I didn't understand everything, but try testdisk or QTparted.

Archangel-13 12-01-2005 03:11 AM

I'm not quite sure if I understand what you're asking for here but if you are wanting to try to restore you partition table and have not already created a new filesystem overtop of it then you can use:

gpart to attempt to restore the partition table.
(I've used this before and it work quite well, if a little slowly. Last time I checked it was on all Knoppix discs and if not you can download a statically compiled binary from the site.)
or
Testdisk
(which I have not tried and really know very little about)

Hopefully I understood what you were asking for and this helps.

randrake 12-15-2005 02:50 PM

Thanks to all, tried all suggestions but endedup backing up and reinstalling Suse. But thanks for helping it was appreciated. :cool:


All times are GMT -5. The time now is 10:29 AM.