-   Linux - General (
-   -   Mandrake 9.2 randomly freezing (

evaprototype00 02-05-2004 05:37 PM

Mandrake 9.2 randomly freezing
So this being my first successful Mandrake install which is great because I've really wanted to get away from windows, but for the past 2 days my computer just seems to randomly lock up totally and requires me to re-power my system. I haven't installed any packages since I installed drake so I'm stumped as to what is going on. As far as I know I checked all my hardware for thermal failure everything is at a normal operating temperature.

My system is as follows
Asus A7N8X-Deluxe
Athlon XP 2500+ (o/c'ed to 2.2 Ghz 3200+)
1 gig of Kingston PC2700 (o/c'ed to PC3200)
Radeon 9800 Non-pro (xfree 4.3 and drivers from
Audigy2 Platinum
WD 100gig (primary drive Windows XP boot) WD 40gig (Mandrake 9.2 Boot)
Sony 40x24x48 CDrom Samsung combo 48x24x48x12

P.S. even with the considerable amount of overclocking Windows XP will run stable for days.

fuzzyworm 02-05-2004 05:44 PM

It would be helpful to have some sort of idea what happens instantaneously before it freezes. I have had / known of various different things that cause this. Most of it is owing to hardware incompatibilities / incorrect installation.

* Laptop or special function keyboards. Certian combination of non-standard buttons may cause it to hang. The solution if this is the case is either to try and find specific linux drivers for your keyboard, avoid pressing the combinations that cause problems, or use a different keyboard.

* Touchpad mice. Though I have only known of 1 case when this has casued a problem. When my friend installed Mandrake, he suffered inexplicable hangs. The problem was eventually traced to his touchpad. Once more, if you cannot find linux drivers, try avoiding contact with the touchpad, using plastic, and use a different mouse.

Sorry I couldn't be of more use, but since there are numerous factors which can cause such problems, it may be worth you giving more information about the circumstances immediately prior to the problem.

evaprototype00 02-05-2004 05:52 PM

Unfortunatly it will do it random at any point in time.

fuzzyworm 02-05-2004 06:03 PM

* Try timing the interval, because it could be a tasked event that is causing it, such as a screensaver, or date checker

* Does it happen when there are no applications visible?

* Have you checked for known problems with your hardware?

* Do you use PCMCIA or USB? Support for these varies, and has been known to cause problems occasionally.

* Did you have any problems during installation?

* Is windows still installed on your computer, and if so, is it on an NTFS drive?

* Is your computer being used in any way over a network, through which other users may be causing the problem? If this is the case you should investigate what they are using.

I hope something here is of use, the most important thing is to look for a pattern. Unlike windows, one of the strong points of Linux is that there is very little random activity, whatever problems may exist, they usually follow a difinite pattern, though this may not be immediately obvious, you should try and find the common factor in this problem. It could be the case that there are two unrelated factors, which would make the pattern harder to spot.

Melkor 02-06-2004 02:16 PM

Mandrake used to do the exact same thing to me as well.

However, with exactly the same hardware, it has yet to freeze up on me while running Slackware.

steve1401 02-06-2004 07:19 PM


I have had exactley the same problem. Similar harware setup - 1GB RAM, AMD3000+ CPU, ATI 9800pro (w/ati drivers et al) & Asus A7N8X.

So far I have struggled to find a solution, but I installed SuSE on the same box and it runs fine.

Did you find a solution. I figured that it may be a kernel config on install. Probably the 1GB of RAM is an issue? I did install w the '4GB' kernel though and it still didn't work??

I haven't had chance to try it yet, but I gather that installing with 'noaspi' configured should be worth a go? (from expert mode apparently)

Please let me know if you have any joy - I much prefer Mandrake than SuSE...


schaez 02-06-2004 11:01 PM

I have the A7N8X deluxe w/ 512MB, 1700+, and ATI9200. I tried Mandrake 10 and it froze on me ( of course it's not released yet). I haven't tried Mandrake 9.2 on this board. I've also had random freezes in Debian when using it's 2.6 kernel or one I've compiled.

pureevil4 04-06-2004 03:25 AM

I have a ATI nf7-s with the same CPU + OC

and my mandrake 10 alsso freeze's up alot of times...

I do have NTFS HD's mounted and i use an USB mouse

could those be the problem?

All times are GMT -5. The time now is 05:03 AM.