LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (https://www.linuxquestions.org/questions/linux-general-1/)
-   -   make - command not found ?? (https://www.linuxquestions.org/questions/linux-general-1/make-command-not-found-64880/)

GreatHornDragon 06-10-2003 08:22 PM

make - command not found ??
 
I am trying to intall Apache on Slackware 9.1. I have extracted and configured it, but when I type 'make' to continue with the process I get the message:

-bash: make: command not found

I have never encountered this before. Could it be some path wrong in my installation of Linux?

Any help is appreciated, thanks.

Dwight.

fancypiper 06-10-2003 08:26 PM

Were you root when you attempted it and did you install the developmental packages for Slackware?

# Guides to software and installation
LNAG - How do I install a program I downloaded from the Internet?
Rute Guide's software explanation

GreatHornDragon 06-10-2003 08:33 PM

I was root, yes. And I did install the D package. Is there some way that I might have skipped make? How can I find tihs out more accurately?

fancypiper 06-10-2003 08:41 PM

Full root or su?

Try

/sbin/make

If that fails, hunt it down:

updatedb
locate make

GreatHornDragon 06-10-2003 08:45 PM

Full root, not su.

/sbin/make didn't work, same problem.

Locating it did not find anything just called 'make', but a heap of 'automake', '***makefile', etc.

fancypiper 06-10-2003 08:54 PM

I don't think you installed it, or you may have missed making a link or something in the orig install.

Try (re)installing it.

GreatHornDragon 06-10-2003 09:08 PM

Thanks... I tried reinstalling the package from the CD (didn't think to even try this...) and it turns out it was corrupt, so it must have skipped it during the install.

I downloaded the latest package from Slackware and it works now. Thanks to all!

fancypiper 06-10-2003 09:18 PM

:cool: I helped a slacker! :D


All times are GMT -5. The time now is 10:50 PM.