LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 01-16-2003, 01:39 AM   #1
moger
Member
 
Registered: Sep 2002
Distribution: Fedora Core 3
Posts: 247

Rep: Reputation: 30
lpd problem


I'm trying to connect a local printer so I can print files from the command line - nothing fancy. This is in Red Hat 8.0. I created a basic /etc/printcap. However, when I restart the lpd, I get:

[root@localhost init.d]# ./lpd restart
Stopping lpd: [ OK ]
Starting lpd: Warning - Rx40: cannot open lp device '/dev/lp0' - No such device

I originally disabled parallel printer support in my kernel, BUT now I DO have it built into my kernel. I also made sure ECP mode was being used for my parallel port in the BIOS. Thoughts?
 
Old 01-16-2003, 07:59 AM   #2
barbanero
Member
 
Registered: Jan 2002
Location: Bucharest
Distribution: RedHat, AIX
Posts: 39

Rep: Reputation: 15
Did you try to configure your printer from gui ( Printer Configuration from System)

match the apropiate driver for your printer from that.
 
Old 01-16-2003, 10:16 AM   #3
Silent1
Member
 
Registered: Jul 2002
Location: Davie, FL
Distribution: Debian
Posts: 33

Rep: Reputation: 15
yeah type as root printconf to get the gui and see if that helps.
 
Old 01-16-2003, 11:07 AM   #4
moger
Member
 
Registered: Sep 2002
Distribution: Fedora Core 3
Posts: 247

Original Poster
Rep: Reputation: 30
No, No GUI tools see's the printer. Here is my /etc/printcap I made:

Rx40 | hplaserjet3 | lp
:sd=/var/spool/lpd/Rx40
:lp=/dev/lp0


Like I said, a very simple printcap file.
 
Old 01-17-2003, 02:02 AM   #5
barbanero
Member
 
Registered: Jan 2002
Location: Bucharest
Distribution: RedHat, AIX
Posts: 39

Rep: Reputation: 15
Here is my /etc/printcap:

lp0:\
:ml=0:\
:mx=0:\
:sd=/var/spool/lpd/lp0:\
:af=/var/spool/lpd/lp0/lp0.acct:\
:sh:\
:rm=xxx.xxx.xxx.xxx:\
:rp=lp0:\
:lpd_bounce=true:\
:if=/usr/share/printconf/util/mf_wrapper:

My printer is HP LaserJet 5 - Network printer

xxx.xxx.xxx.xxx is the ip of printer
 
Old 02-17-2003, 02:19 PM   #6
saturn_vk
Member
 
Registered: Feb 2003
Location: Sofia
Distribution: slackware
Posts: 104

Rep: Reputation: 15
are you sure you enabled the parallel printer from the character devices section?

i had the same situation, and it turned out that i had forgotten to enable it, but only enabling the parallel port.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
lpd problem J_Szucs *BSD 1 06-13-2005 08:10 PM
lpd problem ltrain Linux - Networking 3 11-11-2004 12:19 PM
LPRng - LPD problem robinhood1995 Linux - General 0 04-21-2002 12:57 PM
lpd problem - please help SSUHALE Linux - General 0 09-07-2001 01:18 PM
Printing problem: with lpd? bazell Linux - General 0 04-10-2001 10:20 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 12:34 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration