LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 05-20-2004, 12:34 PM   #1
drigz
Member
 
Registered: Apr 2004
Distribution: Gentoo ~x86
Posts: 407

Rep: Reputation: 30
lose console framebuffer on kernel rebuild


when i installed slackware, i told it to use the 1024x768x64k framebuffer console, and this worked. however, when i did a kernel rebuild, i lost this. it hasnt changed my lilo.conf, and i enabled the following kernel options:
Support for frame buffer devices
VESA VGA Graphics Support
Framebuffer console support
Bootup Logo
[All logos]

what did i do wrong - i want it back, and am not afriad to do another kernel compile (i had to do about 8 in a row a while ago to get my sata hard drive to work...)

my graphics card is a nvidia geforce fx5600 256mb and i have the drivers.
 
Old 05-20-2004, 01:24 PM   #2
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 250Reputation: 250Reputation: 250
You left framebuffer support out of the kernel most likely.. you'll have to go back and add the support.

The lilo options don't do jack if the support isn't there.
 
Old 06-04-2004, 04:58 AM   #3
drigz
Member
 
Registered: Apr 2004
Distribution: Gentoo ~x86
Posts: 407

Original Poster
Rep: Reputation: 30
i missed out an option called like selection or something - got it now
 
Old 06-05-2004, 12:53 AM   #4
sharpie
Member
 
Registered: Jan 2004
Location: California
Distribution: Slackware 10.1
Posts: 190

Rep: Reputation: 30
Quote:
Originally posted by drigz
i missed out an option called like selection or something - got it now
I'm also having this problem, was the option you missed out under "Device Drivers>Graphics Support>Support for frame buffer devices"?

Edit: I'm using kernel 2.6.5, so perhaps the way to get to it is different.

Edit 2: I found an option called "Video mode selection support", looking at the help tells me this is what you missed out. Does anyone know if I need to add the option "Support for frame buffer devices" as well?

Last edited by sharpie; 06-05-2004 at 12:57 AM.
 
Old 06-05-2004, 05:12 AM   #5
drigz
Member
 
Registered: Apr 2004
Distribution: Gentoo ~x86
Posts: 407

Original Poster
Rep: Reputation: 30
you need like 5 options enabled. just tick everything in the console framebuffer section unless its obviously bad. thats what i did nad it worked for me. i warn you though, i ended up with 2 penguins at the top, probs because i ticked all the bootup logos. its not worth a recompile tho.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
VESA framebuffer vs Intel framebuffer in Slackware 10.0 with default kernel brancalessio Slackware 3 01-20-2005 03:21 PM
recompile 2.6 kernel with framebuffer console m_yates LinuxQuestions.org Member Success Stories 1 07-21-2004 07:42 AM
Framebuffer Console Help Crazed123 Linux - Software 5 07-29-2003 02:10 PM
Framebuffer Console jspenguin Linux - General 3 02-28-2003 08:21 AM
Framebuffer Console Jesus Slackware 6 05-02-2002 12:55 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 07:49 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration