-   Linux - General (
-   -   Long delay and error message starting remote X session (

lotus49 10-10-2004 04:08 PM

Long delay and error message starting remote X session
I have just installed FC2 (fully patched) on one of my machines and I have been trying to set up LTSP.

Everything was working fine (I hadn't got LTSP fully working but everything else was OK) but a strange error has appeared.

Every time I login to X remotely or run a Gnome-Terminal in a remote X session there is a long (several minutes) delay and (in the case of starting a shell in a Gnome-Terminal) the following error appears:

Couldn't open connection to tewit:9200: Connection timed out

Apart from the long delay, everything works fine.

The name of the machine I am logging in from is tewit. This error does not appear if I ssh to the box from tewit.

Port 9200 doesn't mean anything to me and the only references I could find to it are in relation to Lexmark printers and Wireless Application Protocol, neither of which I use.

Since I only installed the OS yesterday, I have been making a lot of changes to it but the only changes I have made very recently relate to LTSP. I have installed tftp and reconfigured syslog to accept remote logging - I cannot see that either of these is relevant.

Can anyone suggest where to look to find the problem?

maroonbaboon 10-11-2004 01:06 AM

Connection delays can be caused by the server attempting a reverse DNS lookup in order to fully ID the source of the incoming connection.

To get around this you could try putting an entry in the server's /etc/hosts file for the machine trying to connect. Here's a link with a discussion of a similar issue:

lotus49 10-11-2004 12:28 PM

Thanks for the response, but I am running a nameserver in the domain and I have just tried doing a reverse lookup manually and it works fine. I can get the correct hostname of the remote host if I supply the ip address to the server. I have also tried adding the appropriate entry to the hosts file on the server but it made no difference.

The thing that baffles me the most is the (apparent?) reference to port 9200. It certainly appears that the server is trying to contact the client on that port and, unsurprisingly, getting no response.

lotus49 10-11-2004 01:20 PM

OK I have now sorted this out.

The problem was the ltsp-sound package that I had installed. This presumably tries to connect to some client program running on an LTSP client host. The version of LTSP I am configuring has that built in but the computer I was running the remote X session on is an XP box running eXceed which doesn't have sound support (so far as I know).

The reason I couldn't find any reference to port 9200 is presumably because the LTSP project just adopted it and it isn't official.

All times are GMT -5. The time now is 09:11 PM.