LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 01-15-2004, 05:59 AM   #1
Chris H
Member
 
Registered: Aug 2003
Location: Farnborough, UK
Distribution: Zenwalk
Posts: 288

Rep: Reputation: 30
Logging into KDE, Debian


Just installed Debian Woody (stable) and am wallowing in nostalgia. KDE 2.2? Ye Gods!.

Still, it's working well

Anyways, I've changed the /etc/innitab to boot to runlevel 4 (hope that's right?) so it goes straight to the KDE login screen. For whatever reason it now boots into a Debian login screen? where the only option is 'login'. It also goes to here when I logout.

Being a dual booting machine I want other family members to be able to logout of Debian and be presented with the KDE screen with an option of shutdow/reboot/login etc.

Trying not to have to make people to pull the plug out of the back of the pc when they want to reboot into windows. Would like to get the 'traditional' KDE login screen showing.

While I'm here any good sites/tutorials on apt-get?

Ta
Edit: Just found the apt-get guide on debian

Last edited by Chris H; 01-15-2004 at 06:23 AM.
 
Old 01-16-2004, 11:12 AM   #2
Rounan
Member
 
Registered: Jun 2003
Location: Ontario
Distribution: Ubuntu, Gentoo, Debian
Posts: 416

Rep: Reputation: 30
Only thing I can recommend is ditching good'ol KDE 2.2 and upgrading! :P

I'm now running a modified Woody system with KDE 3.1, and the Debian menu I get popping up has options to reboot/halt/etc.

Add a testing or unstable source to /etc/apt/sources.list (I installed from unstable, and so far it's stable. ):

deb <local mirror here>/debian testing main contrib non-free
or
deb <local mirror here>/debian unstable main contrib non-free

then do:
apt-get update
apt-get install kde

This will install KDE 3.1 and its required dependancies only - you may want to remove the extra source so you can apt-get upgrade without installing everything unstable. But this might confuse apt, too. There's definately an intelligent way to tell it to keep KDE at that version and treat other packages as coming from 'stable', but I don't know what it is.

If you don't want to change KDE, then I'm afraid I don't know enough about the Debian screen to help.

Cheers,
--Rounan
 
Old 01-16-2004, 02:33 PM   #3
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,684

Rep: Reputation: 120Reputation: 120
Re: Logging into KDE, Debian

Quote:
Originally posted by Chris H
Just installed Debian Woody (stable) and am wallowing in nostalgia. KDE 2.2? Ye Gods!.

Still, it's working well

Anyways, I've changed the /etc/innitab to boot to runlevel 4 (hope that's right?) so it goes straight to the KDE login screen. For whatever reason it now boots into a Debian login screen? where the only option is 'login'. It also goes to here when I logout.

Being a dual booting machine I want other family members to be able to logout of Debian and be presented with the KDE screen with an option of shutdow/reboot/login etc.

Trying not to have to make people to pull the plug out of the back of the pc when they want to reboot into windows. Would like to get the 'traditional' KDE login screen showing.

While I'm here any good sites/tutorials on apt-get?

Ta
Edit: Just found the apt-get guide on debian
You want to install kdm and change the runlevel back to the default it was the levels 2-5 are all the same in Debian unless you change the behavior by modifing or deleting the entries in the /etc/rc[2-5].d directories. Once kdm is installed it should run and present you with a login screen.
Code:
[04:16 PM Fri Jan 16: stephen @ ~]
>$ ll /etc/rc2.d/
K11anacron        S20apmd           S20inetd          S89atd
S10sysklogd       S20autofs         S20lpd            S89cron
S11hotplug        S20cupsys         S20makedev        S99kdm
S11klogd          S20dictd          S20ssh            S99rmnologin
S19spamassassin   S20exim           S20xfs            S99stop-bootlogd
S20alsa           S20hddtemp        S89anacron
[04:16 PM Fri Jan 16: stephen @ ~]
>$ ll /etc/rc3.d/
K11anacron        S20apmd           S20inetd          S89atd
S10sysklogd       S20autofs         S20lpd            S89cron
S11hotplug        S20cupsys         S20makedev        S99kdm
S11klogd          S20dictd          S20ssh            S99rmnologin
S19spamassassin   S20exim           S20xfs            S99stop-bootlogd
S20alsa           S20hddtemp        S89anacron
[04:16 PM Fri Jan 16: stephen @ ~]
>$ ll /etc/rc4.d/
K11anacron        S20apmd           S20inetd          S89atd
S10sysklogd       S20autofs         S20lpd            S89cron
S11hotplug        S20cupsys         S20makedev        S99kdm
S11klogd          S20dictd          S20ssh            S99rmnologin
S19spamassassin   S20exim           S20xfs            S99stop-bootlogd
S20alsa           S20hddtemp        S89anacron
[04:16 PM Fri Jan 16: stephen @ ~]
>$ ll /etc/rc5.d/
K11anacron        S20apmd           S20inetd          S89atd
S10sysklogd       S20autofs         S20lpd            S89cron
S11hotplug        S20cupsys         S20makedev        S99kdm
S11klogd          S20dictd          S20ssh            S99rmnologin
S19spamassassin   S20exim           S20xfs            S99stop-bootlogd
S20alsa           S20hddtemp        S89anacron
If it does not start kdm automatically or uses another check the alternatives:
Code:
HappyTux:/home/stephen# update-alternatives --display x-session-manager
x-session-manager - status is auto.
 link currently points to /usr/bin/kde3
/usr/bin/kde3 - priority 40
Current `best' version is /usr/bin/kde3.
Change the --display to --config if you need to change it.
 
Old 01-16-2004, 07:02 PM   #4
Chris H
Member
 
Registered: Aug 2003
Location: Farnborough, UK
Distribution: Zenwalk
Posts: 288

Original Poster
Rep: Reputation: 30
Cheers all.

Installed kdm and it worked. However it then refused to let me log in as root, the progress box crashed just leaving the splash background.

Have reinstalled Slack
 
Old 01-16-2004, 07:51 PM   #5
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,684

Rep: Reputation: 120Reputation: 120
Quote:
Originally posted by Chris H
Cheers all.

Installed kdm and it worked. However it then refused to let me log in as root, the progress box crashed just leaving the splash background.

Have reinstalled Slack
That is exactly what it is supposed to do you should not run X as root, does Slackware let you do that gaping security hole by default??? You should always login as normal user and then use su to become root and then run anything you need that way from a console window.
 
Old 01-17-2004, 06:52 AM   #6
Chris H
Member
 
Registered: Aug 2003
Location: Farnborough, UK
Distribution: Zenwalk
Posts: 288

Original Poster
Rep: Reputation: 30
But using the x login screen it allowed me to log in as root. The kdm login problem was an error somewhere. Never used a distro that doesn't allow logging into X as root.

Some installers like openoffice.org require the X server to be available as root cos they use gui installers. SU as a user and root doesn't have access to the X server cos user is using it. Least that's what happens in Slack if you try and run OOo's installer from a user login and su as root.
 
Old 01-17-2004, 02:00 PM   #7
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,684

Rep: Reputation: 120Reputation: 120
Quote:
Originally posted by Chris H
But using the x login screen it allowed me to log in as root. The kdm login problem was an error somewhere. Never used a distro that doesn't allow logging into X as root.

Some installers like openoffice.org require the X server to be available as root cos they use gui installers. SU as a user and root doesn't have access to the X server cos user is using it. Least that's what happens in Slack if you try and run OOo's installer from a user login and su as root.
Well you have now in Debian it is disabled by default because of security it can be enabled by editing the kdmrc file to allow root login. You can run X apps as after su'ing to root at least that how it works on my box it will just error when you run the program telling you that it is disabled for security reasons then suggest if you wish to run with the -s option (eg. application -s in a console window) you can override and run the application.
 
Old 01-17-2004, 02:15 PM   #8
Chris H
Member
 
Registered: Aug 2003
Location: Farnborough, UK
Distribution: Zenwalk
Posts: 288

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by HappyTux
......then suggest if you wish to run with the -s option (eg. application -s in a console window) you can override and run the application.
Cheers for that -s switch, tis worth knowing.
 
Old 02-19-2004, 09:52 AM   #9
rockee
Member
 
Registered: Feb 2004
Posts: 36

Rep: Reputation: 15
Quote:
Originally posted by Chris H
Cheers for that -s switch, tis worth knowing.
My problem.

Installed Debian "woody".
Reboot.

Entry is directly into GUI screen asking for login name. When I try to login is root, I am unable to, giving me the message that root is uab et o login through this screen. I login as the user I created, and am able to, but display mode is incorrect. I try to logout, so that can use root at shell and never can get back to shell.

A few questions:
1. Why am I going diirectly to X-server mode?
2. How can I reconfig display? (Cannot run Xconfigirator at shell)
3. How can I login as root at prompt?
 
Old 02-19-2004, 10:12 AM   #10
Rounan
Member
 
Registered: Jun 2003
Location: Ontario
Distribution: Ubuntu, Gentoo, Debian
Posts: 416

Rep: Reputation: 30
1) Because your init scripts are set up to have it work that way. If you don't want to have X come up automatically, you need to edit those scripts. Start here:
http://www.debian.org/doc/debian-pol...tml#s-sysvinit

To use a shell terminal is dead simple: ctrl-alt-F1 through ctrl-alt-F6
This will give you a virtual terminal. ctrl-alt-F7 to switch back to Xserver.

But why not use a terminal in X? konsole or xterm do this, and associate it with the xserver login so you can call gui tools from the commandline.

--Rounan
 
Old 02-19-2004, 11:24 AM   #11
rockee
Member
 
Registered: Feb 2004
Posts: 36

Rep: Reputation: 15
Quote:
Originally posted by Rounan
1) Because your init scripts are set up to have it work that way. If you don't want to have X come up automatically, you need to edit those scripts. Start here:
http://www.debian.org/doc/debian-pol...tml#s-sysvinit

To use a shell terminal is dead simple: ctrl-alt-F1 through ctrl-alt-F6
This will give you a virtual terminal. ctrl-alt-F7 to switch back to Xserver.

But why not use a terminal in X? konsole or xterm do this, and associate it with the xserver login so you can call gui tools from the commandline.

--Rounan
Am reinstalling Debian as I am writing this.

I did not setup the init script this way to go into X, yet it defaulted to this. I wil try usimg the CTRL keys as you sugegst to try to change the script. Should I be able to use Xconfigurator?

WIll check back in soon.
 
Old 02-19-2004, 12:38 PM   #12
Rounan
Member
 
Registered: Jun 2003
Location: Ontario
Distribution: Ubuntu, Gentoo, Debian
Posts: 416

Rep: Reputation: 30
Didn't say YOU set them up this way. It is the default configuration - just have to change it if you don't like it. Thinking is, if you've installed an X server then you're going to want it running if only to have the functionality of xterm instead of VGA consoles. If you're running a server and don't want to waste resources on an Xserver... well, you wouldn't install one then, would you? So if you want an x server installed but not running by default, you just have to tweak some scripts.

BACK THINGS UP BEFORE CHANGING THEM.
I can't stress this enough. If this is your first time messing with things like config files and init scripts, YOU WILL MESS IT UP. I did. I still do.
A simple: cp <file_to_edit> <<file_to_edit>.old will save you worlds of hurt.

--Rounan
 
Old 02-20-2004, 08:52 PM   #13
rockee
Member
 
Registered: Feb 2004
Posts: 36

Rep: Reputation: 15
Quote:
Originally posted by Rounan
Didn't say YOU set them up this way. It is the default configuration - just have to change it if you don't like it. Thinking is, if you've installed an X server then you're going to want it running if only to have the functionality of xterm instead of VGA consoles. If you're running a server and don't want to waste resources on an Xserver... well, you wouldn't install one then, would you? So if you want an x server installed but not running by default, you just have to tweak some scripts.

BACK THINGS UP BEFORE CHANGING THEM.
I can't stress this enough. If this is your first time messing with things like config files and init scripts, YOU WILL MESS IT UP. I did. I still do.
A simple: cp <file_to_edit> <<file_to_edit>.old will save you worlds of hurt.

--Rounan
Running Woody.

Still having some problems.

Did some research on not starting Xserver upon boot and saw that need to change the default run level, yet default is currently set at 2, which is supposed to be a terminal window, yet am still starting X-server by default.

Main problem is when I run X, the displayable window is not filling my screen entirely. Resolution is very good, though. Can run each window mgr just fine. When I try to display a window, I cannot see the bottoms of some windows becuase the screen area is too small, and I can't "reach" the botom edge to move them up. Do you know how to expand the window to make it larger? I have specified 24 bits, and can use display modes up to 1024X768. I Have tried regenerating the XF86Config-4 file and it still generates the same as it is now. Any ideas?
 
Old 02-22-2004, 09:18 AM   #14
Rounan
Member
 
Registered: Jun 2003
Location: Ontario
Distribution: Ubuntu, Gentoo, Debian
Posts: 416

Rep: Reputation: 30
I don't know why you'd be running into the strange window-size thing.
Does the cursor stop at the edge of your screen? Is the problem that the xserver isn't generating that part of the screen, or that the monitor just isn't displaying it?
Try playing around with the size/position controls on your monitor and see if you can center the display.
Barring that, I don't know what could be causing it.

As for the runlevel issue, I'm running into the same thing at the moment - gonna do some research today and hopefully get it set up properly. I'll post anything I come up with.

--Rounan
 
Old 02-22-2004, 10:10 AM   #15
rockee
Member
 
Registered: Feb 2004
Posts: 36

Rep: Reputation: 15
Quote:
Originally posted by Rounan
I don't know why you'd be running into the strange window-size thing.
Does the cursor stop at the edge of your screen? Is the problem that the xserver isn't generating that part of the screen, or that the monitor just isn't displaying it?
Try playing around with the size/position controls on your monitor and see if you can center the display.
Barring that, I don't know what could be causing it.

As for the runlevel issue, I'm running into the same thing at the moment - gonna do some research today and hopefully get it set up properly. I'll post anything I come up with.

--Rounan
I did some searching and this is part of a link I found concerning the display I am using. NOt my words, but part of another posting somewhere else:
"The screen is too small to even fit some KDE configuration dialog boxes, forcing you to use a virtual desktop larger than the physical screen (I hate that scrolling), or forcing you to try gymnastics with the window sizes, etc.
...While configuring KDE, I was quite desperate to get more screen real estate. So I switched the task bar at the top to disappear out of sight when not used, and likewise to the panel at the bottom. I also set the panel to small size. All this can be done by clicking on various checkboxes in the ``Applications'' section of the KDE Control Centre."
So, apparently on some displays, the screen is not filled entirely. I Ihave tried playing with the "Virtual x y" parameter in the "SCreen display" portion of the "XF86Config-4" file to see if there is a way to make my virtuual dislap size larger.

So, right now I have 2 problems:
1. Not being able to boot directly into an shell. The reason I want to do this is to fool around with the "XF86Config-4" file, since you can't change this obviously while in X. You can, but it doesn't make sense without stopping X. So, what I need to do is to use "CTRL/ALT/BACKSPACE" to stop X and eventually I get out, if I hit the keys just right
2. Being able to run full screen versus partial screen.

Also two questions:
1.Looking at the posting I copied above, do you know which checkboxes are being referred to to get rid of the task bar and the panel?
2. Supposedly, by hitting the "CTRL/ALT/+" and or "CTRL/ALT/-" keys you can cycle through display resolotiions. This doesn't seem to work for me.

Sorry for all of these questions, but I have tried searching for the answers and haven't been able to come up with them.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how to disable console logging (Debian Sarge) retiem Linux - Networking 8 06-14-2013 06:23 AM
howto enable logging from BIND 9 on Debian Sarge ? cccc Debian 2 07-07-2005 06:43 PM
KDE crashes when logging out update Slackware 1 06-06-2005 10:21 PM
problem logging into KDE 3.1 tmaly SUSE / openSUSE 3 04-04-2005 02:19 PM
4 second freeze on keystroke when logging into kde 3.3 on debian striderstrahan Linux - Software 1 09-07-2004 06:18 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 08:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration