LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (https://www.linuxquestions.org/questions/linux-general-1/)
-   -   Locked VFAT Drive, can't Unlock (https://www.linuxquestions.org/questions/linux-general-1/locked-vfat-drive-cant-unlock-273443/)

Kenji Miyamoto 01-03-2005 06:36 PM

Locked VFAT Drive, can't Unlock
 
For some reason, when I tried # chmod 777 "/mnt/win_c2", it locked the drive. I can't figure out how to unlock it, either. Initially, I was trying to make it so I could access the folder as a normal user, but it went horribly wrong.

michaelk 01-03-2005 06:39 PM

chmod does not work on a mounted vfat partition.

Add the option umask=000 to the fstab entry for read / write access by all users.

Kenji Miyamoto 01-03-2005 07:48 PM

Okay, that unlocked it, but I still can't write to it as a normal user.

michaelk 01-03-2005 08:54 PM

maybe remounting partition or
try umounting the partition
chmod 777 /mnt/win_c2
remount partition.

Kenji Miyamoto 01-04-2005 12:19 AM

Quote:

Originally posted by michaelk
maybe remounting partition or
try umounting the partition
chmod 777 /mnt/win_c2
remount partition.

That didn't work. It just reset the permissions when remounting.

michaelk 01-04-2005 07:56 AM

Post the fstab entry for this partition.

Kenji Miyamoto 01-04-2005 07:48 PM

Quote:

Originally posted by michaelk
Post the fstab entry for this partition.
Code:

/dev/hdb2              /mnt/win_c2            vfat    defaults,      0 0 umask=000

JunctaJuvant 01-04-2005 07:54 PM

I think the umask=000 bit should be in the options section, like this:
Code:

/dev/hdb2              /mnt/win_c2            vfat    defaults,umask=000      0 0

Kenji Miyamoto 01-04-2005 09:50 PM

Quote:

Originally posted by JunctaJuvant
I think the umask=000 bit should be in the options section, like this:
Code:

/dev/hdb2              /mnt/win_c2            vfat    defaults,umask=000      0 0

I tried that before, and it said that the line was invalid when I rebooted.

michaelk 01-04-2005 10:28 PM

Can you post the exact error?
Is this the last line in the file? If so make sure there is an end of line character. Move the cursor to the end of the line and press the enter key.


All times are GMT -5. The time now is 01:24 PM.